[Solved] Sound volume via HDMI suddenly very low

I’ve been running the Le Potato for about a month now and all was well till a few days ago.
It’s always powered on and when I switched to the TV HDMI input and started a episode there was no sound. At least, that is what I thought at first.

Seems audio is played but at a very low volume. With my TV I listen between 12 and 16 (out of 100) volume setting. Now, I need to up the volume to 70.
No settings have been changed in either Kodi or CoreELEC.

Of course I’ve switch TV HDMI input. I also have a PS4 Pro and a Apple TV hooked up to the TV (on their own HDMI input) and they both have no issues.
With the Le Potato connected to those inputs the volume is still very low.

I’ve also turned the Le Potato off and let it completely disconnected for a day, and also pulled the power from the TV.
Didn’t matter, issue is still there.

I’m kinda at a loss now as to what to try.
I know there is a volume offset, but don’t want to use that as it feels something else is wrong. Possibly even the hardware itself, which for the rest works just fine.

Anyone got an idea what might be going on or experienced this before?

Details: Running version 9.0.3 on a Le Potato 2GB with a 16GB eMMC module.

Have you tried a fresh install (on a card)?

A couple of things that might help.

One, plug a keyboard in and press the + key a few times. kodi’s volume indicator should popup to centre of the screen. It’s possible that kodi’s internal sound level ended up turned down some how. Use + and - keys to adjust volume level if this is the case.

Two, check the audio device that you are using, Settings/System/Audio. Try changing it to one that mentions hdmi at the end of it. If it is not already on that one.

I took an SD card and did a fresh write of the image, added my config files (userdata stuff) and sound volume is just fine now.
So at least it’s not the hardware.

I will hook up a keyboard and try the +/- keys. If that is it, no clue how it could have changed.
I only use the remote control from my TV with CEC, so I only adjust the volume of the TV, not Kodi.

Forgot to mention I checked the audio output in Kodi.
It is set to HDMI as it should, but even with the analogue (the option above it) the volume remains very low.

Be back in a bit.

1 Like

The +/- did the trick. Tbh, I didn’t even know Kodi had that key shortcuts.
In all the years I’ve been using Kodi on several platforms, I’ve always used CEC.

For some reason the volume was at one third. Putting it back to 100% and volume was back to normal (for me).

Thanks for the replies!