[SOLVED] Sunvell T95Q (S905X2) cannot boot from USB/SD media


I have a Sunvell T95Q 4/32 tvbox. The hardware is the following:
T95q_20181228_v1.2 (PCB)
Spectek PS054-053BT (DDR4)
Realtek RTL8211F

I tried to boot from various sources:
USB2 Power button - N/A, Context - N/A, App - N/A, RESET - Stock bootloader
USB3 Power button - Blue led / Black screen, Context - same, App- Same, Reset Same
SD Power button - N/A, Context - N/A, APP- N/A, RESET N/A

I couldn’t find a suitable file for this model in the device tree section.


What have you tried


I tried the latest generic X905X2 (CoreELEC-Amlogic-ng.arm-9.2.1-Generic.img.gz). I didn’t try other T95 image.

What dtb.img are you using ?

I did’t not use any extra dtb.img because I couldn’t find any appropriate dtb file for my player.

the dtb’s are in the device tree folder, try each one in turn if it doesn’t boot

1 Like

First you need to read this: How to install CoreELEC

1 Like

I have skipped the fourth step. :slight_smile:

Finally it’s booting. Unfortunately the LAN adaper (RTL8211F) doesn’t work. I am using a generic X905X 4G dtb. Is there any way to inject the RTL8211F driver into the package?

There is no problem with the driver, you’re using the wrong DTB.
Use the one with 1gbit suffix.

1 Like

Now it’s okay with the 1g suffix firmware.