[solved] Unable to blacklist Meson IR since CoreELEC 9.2.3

So ive just upgraded my ODROID N2 from CoreELEC 9.2.2 to 9.2.3 and it looks like the blacklisting of the Meson IR now doesnt work. i have a boot script which does the following:-

# disable 'meson-ir' (odroid built in ir receiver), we use the much better 'mceusb' (microsoft ir receiver)
if [ ! -f '/storage/.config/modprobe.d/00-disable-meson-ir.conf' ]; then
        echo "blacklist meson-ir" > '/storage/.config/modprobe.d/00-disable-meson-ir.conf'

# other method (may be required) to disable 'meson-ir' (odroid built in ir receiver), we use the much better 'mceusb' (microsoft ir receiver)
touch '/storage/.config/remote.disable'

neither method now blacklist the meson ir, any ideas how i can disable the meson-ir on a ODROID N2?.

Remote control has been redesigned a little.
To completely disable remotes (both meson-ir and meson-remote)

mount -o remount,rw /flash
touch /flash/remote.disable
mount -o remount,ro /flash

or just

touch /storage/.config/remote.disable

I think this should help you.

But now I see you already use /storage/.config/remote.disable which should diable loading any module.

Is meson-ir still loaded in your case?

yes i tried that as i saw it as a solution in another post (see op), that didnt work for me.

so i did a find on meson and found the driver name is now ‘meson_uart’ so changed the blacklist to the following which sorted it:-

# disable odroid built in ir receiver (meson-ir), we use the much better 'mceusb' (microsoft ir receiver)
if [ ! -f '/storage/.config/modprobe.d/00-disable-meson-ir.conf' ]; then
        echo "blacklist meson_uart" >> '/storage/.config/modprobe.d/00-disable-meson-ir.conf'

As to the reason why i want to do this, its because i use a microsoft MCE remote and the MCE IR is just so much better than the built in IR receiver in the ODROID N2 as far picking up the signal, hell i can have the remote pointing in the opposite direction and it still works with the MCE IR, the ODROID N2 IR receiver cannot do this, at least it cannot do this when being used with the MCE remote.

it must be, i am getting double remote clicks, if i cover up the MCE IR then it works as single clicks (expected), so it must be still loaded, the blacklist of the new driver works for me, so im happy enough with that as a solution.

meson-ir should not be loaded. But you can check loaded modules by

lsmod | grep meson

As you can see here both modules are already blacklisted by default

and only appropriate one is loaded (or none is loaded).

ok let me check that for you…

EDIT - OK now i am a little confused, so i removed the blacklisting of ‘meson_uart’ from ‘/storage/.config/modprobe.d/00-disable-meson-ir.conf’ and rebooted and the remote is still working ok, i am 100% sure i rebooted after do a ‘touch ‘/storage/.config/remote.disable’’ and that did not sort it for me but now it seems ok - do any blacklist entries get written to /flash perhaps and thus ‘blacklist meson_uart’ is still present?.

Only meson-ir and meson-remote are blacklisted by default and you can’t overwrite it (and you don’t need to).

Everything you do to blacklisting other modules like meson_uart it is all done from user.

Check if you have blacklisted somewhere else?

fgrep -r meson_uart /storage/.config/modprobe.d/

nothing matches for fgrep, ok weird, it looks like its now working as expected just using the command below (including to be clear in case anybody spots this post):-

touch '/storage/.config/remote.disable'

thanks for your help!.

You can check if meson_uart is loaded or not with lsmod

lsmod | grep meson_uart

it looks like it isnt loaded.

So all good at the end :smiley:

1 Like

absolutely, thanks for the help and for replying so quickly - marked solved.

1 Like