[Solved] What player is running?

Hello there,
When I start to play a video or music with OK in the library, is there a way to chek what is the player running with the GUI or SSH command line?

Thanks

What do you mean?

I mean the software that play the video or audio file.
For video there is for exemple DVDPlayer, for music PAPlayer. It is possible to install other player.
After starting to play a media file, I’d like to check what player software is running.

During playback of media?
Is that what you mean?

Attach keyboard ctrl+shift+o

Top left corner will display

Or just the letter o all by it self

Or pause during playback and move to settings

You don’t understand, Kodi is the player. There are just other decoder in use depending on the media.

I think he wants to install external players like you can do on other platforms. Don’t think that’s available in CE.

https://kodi.wiki/view/External_players

You are right rome1931, I want to listen music with another player as It’s not possible to pasthrough DSD stream with stock player.
See this thread

I tried with keyboard but could not find a way to show the player name.
Maybe with ssh, what command?

You will not believe it but the name of the player is - Kodi :wink:

Sholander, do you say kodi is an executable file? but could you let me know what is PAPlayer? and explain me this link §Audio player cores
Moreover what is DVDPlayer? Could you explain this link §Video player

In ssh you can use

grep Player /storage/.kodi/temp/kodi.log


2024-05-10 18:31:46.055 T:1459     info <general>: Default Video Player: VideoPlayer
2024-05-10 18:31:46.055 T:1459     info <general>: Default Audio Player: paplayer
...
2024-05-10 18:32:03.858 T:1590    debug <general>: PAPlayer::Process - Playback started
2024-05-10 18:32:03.964 T:1487     info <general>: PAPlayer::PrepareStream - Ready

or 

2024-05-10 18:38:09.128 T:1677    debug <general>: Thread VideoPlayerAudio start, auto delete: false
2024-05-10 18:38:09.128 T:1677     info <general>: running thread: CVideoPlayerAudio::Process()

Thank you emveepee, this is what I was looking for.
Just the path you provided is different with Coreelec.
The right path is

/storage/.kodi/temp/kodi.log

Maybe you could edit your post and change for the good path in Coreelec?
Many thanks