Some videos don't change resolution/refresh rate of TV

Hi all, first post…

Videos from my new phone do not change the resolution/fps of the TV. This is happening only when I try to play these videos, which are taken at 4K/60fps. Resolution/fps stay the same as whatever I have in Settings > System > Display (which is 1080p/60).
However, as the video plays I can select and switch to the correct resolution/fps in Video settings > Select resolution onscreen menu, because I have whitelisted all the 2160p modes.

Videos from other devices (also 4K) do change the resolution automatically, as expected.

I have tried every possible setting, as well as the recommended ones, updated CoreELEC/Kodi but the problem isn’t solved. Can you help?

https://wiki.coreelec.org/coreelec:ce_support

I tried to upload the log using SSH and Coreelec settings but I can’t.
ix.io is taking a break” currently…

I will post it as soon as I can.

Thanks for your patience…

So you did not try last nightly if it solves your issue?
Because there it would work to paste the logs…

Ok, I had the lastest stable 20.2 but I updated to CoreELEC-Amlogic-ng.arm-21.0-Omega_nightly_20240102

The problem remains but I got the log file:
paste.coreelec.org/iqtzx9

My device is H96 Max X3 (S905X3) 4/64 gb

I tested two of the videos that show the issue.

Thank you

You try to play a mp4 h265 file, not avi.
Clear out the white list and the issue maybe solve itself.

Why does it have to be .avi?
I also tried h264 video, same behavior.
Please see paste.coreelec.org/tzm6wO

The last video is from my old phone (.mp4 h265) and resolution/refresh rate change as normal.

I also tried your last suggestion to remove all whitelist entries. Still the same problem…
At least with the whitelist I can Select resolution from the onscreen menu and then enter 2160p/60. But it should change automatically…

Sorry wrong thread.

Why it should switch resolution when your GUI is already set to 4k? Set GUI to 1080p then it should switch frame rate.

But it isn’t 4K!
GUI is always set to 1080p/59.94

Do you enable in Settings/Player/Playback → Adjust display refresh rate => On start/stop ?
I have this option on, and all resolutions whitelisted. This way on my N2 Kodi sends out to TV original file resolution and also switches to original file framerate.

Edit: forgot to mention, I keep my GUI resolution at 3084x2160 at 59.54…

Yes of course, it’s on start/stop

The problem is that Kodi fails to change the resolution for that specific video files.
Everything else plays OK!

Yes, you have vout: 1080p60hz set in GUI but you did not clean out the whitelist!
Best is to try a clean fresh install.

I might have missed it, but did you send a link with that specific video, or a small clip for testing purpose?

There is a difference in frame rates between tested videos; fps: 60.195 vs fps: 59.940.
Maybe the frame rate 60.195 does not satisfy Kodi’s “WHITELIST - *Searching for an exact resolution with an exact refresh rate” condition so you end up with 1920x1080 @ 59.94

I would be happy to do so, because I really believe this is something that devs should take a look into.
I don’t think there is something wrong on my end.
Can you please point me as to how/where can I send a testing clip?

Also I tried to remove everything from whitelist as @Portisch suggested but then everything plays at whatever the GUI is set to.

Please backup if you want your current setup and try with a clean build. You must have logs without banned repo/addons if you want support. Until then no support is given.

Ok, I just did a fresh installation of stable (Nexus) and then updated to latest nightly in order to post the log.
paste.coreelec.org/pGjnEV

I played 4 videos. The first one changes the resolution/refresh rate as expected.
The other three show the problem. Resolution and refresh rate remain the same as the GUI’s.

Thanks for your help…

In your log it shows the system trying to match the resolution/refresh rate of your videos to the one in the whitelist and finding none. Those are abnormal refresh rates it seems. If you want to provide some short samples we can try in our side. Also, if you can, provide a log with Gui set to 1080p and no whitelist settings with the same videos.

Log with GUI set to 1080p/60 - No whitelist
paste.coreelec.org/6BU07w

Also, please tell me how to provide video samples for you to test…