Sorting the movie library alphabetically incorrect

In CoreELEC 19 I have the problem that the entries in the movie library are not sorted alphabetically correctly. Even films with the same title do not appear one below the other, sequences of numbers are not adhered to.
Here are two examples:

In addition, I tested CoreELEC 20 Nexus RC1. It looks the same there as under CoreELEC 19.
Also tested: LibreELEC 10.0.3 (via USB stick on the PC) - sorting correct.

I’ve had this problem since the first release candidates from CoreELEC 19 to the current 19.5 RC3. If I change the sort order from title to original title and then go back to title, the order is correct. But only until I leave the list. As soon as I call them up again (even without restarting KODI or CoreELEC), they are sorted incorrectly again.

It is probably not a problem with the movie library/database, but a fundamental problem with the alphabetical sorting under CoreELEC 19. This behavior is also evident in file mode.

Here’s an example:
There are 251 video files in a folder on my NAS that have NOT been included in the movie library. The folder is outside of the library paths. It contains the files CE_V0001 to CE_V0247 (numbered consecutively, different file extensions) and the files CE PCA22 (1) to CE PCA22 (4). If I open this folder, sorted by name, the following appears:

So now there is no correct sorting by name. The exact same result can be replicated any number of times.
Sorting is correct in Kodi 19.5 on Windows.
On my second TV with an X96 Max Plus and CoreELEC 19.5 I get the same result, the exact same puzzling sorting as shown above.
CoreELEC 20 seems to have the same bug. CoreELEC 9.28 sorts correctly but is deprecated.

Could you make a zip archive of few files to replicate here with same files in one folder?
You can send me PM if you don’t want to share in public.

CE have some extra sort included, not sure if this can cause it.

Attached is the archive with the video files. These are not the original files as they are private. There are 6 clips from the same movie. The sorting error shows up here too.
Files.zip (8.6 MB)

Thanks. I can replicate behaviour but don’t know why it doesn’t work as it should.

But I noticed one thing. If I sort by size and then again by name the sorting is wrong. But going one folder up and then again in this folder it makes files sorted correctly. Like something is not refreshed correctly.

I also noticed something about the example from my first post with the Star Trek movies in the movie library: Star Trek 2, 3, 5 and 6 are on the same source, Star Trek 4, 7, 8 and 9 on a second one, also common source. It is precisely these four films from the second source that are incorrectly sorted.

Sorting by original title is only available in CE I think.
I assume there is some general issue with sorting on CE. Will do some more tests.

Right. There is no original title sorting in Kodi on Windows. Also not in LE. Not in CE 9.2.8 either.

Can I make you one test image? Which one exactly?

Thanks. I would like to do a test. Preferably CE 19.5.

Here it is 236 MB file on MEGA

This fixes sorting by name.

Thanks very much!
Sorting works perfectly. Both in library and in file mode.

1 Like

Great. Thanks for testing. Will send PR to Kodi.

1 Like