SSH Password not changing

I have somehow botched my SSH password, so I am trying to change it via the menu, and it says it changed, but when I go to login, I get ‘access denied’ I know the user is ‘root’. Is there a way I can manually change the password without being able to SSH into the machine?

I don’t know if this will help but have you looked at the settings in the CoreELEC Configuration addon?

Under Services, there are settings for disabling the SSH password and setting a new one.

I have tried that, it will say it set the password, but then when I try to login, it says access denied. I am thinking the only fix is going to be reinstall. Thankfully I backed up my addons, and addon settings while it was all working.

What happens if you select the option to disable the Password and use the default one?

I set ‘Disable SSH Password’, and get this “No supported authentication methods available(server sent: publickey, keyboard-interactive)”.

The Disable SSH Password option disables username/password login in place of public key authentication. That behaviour is expected in the absence of an authorized_keys file in ~/.ssh

See:
https://kb.iu.edu/d/aews

About | FAQ | Terms of Service | Privacy Policy | Legal Notice