Stock on Logo when Installing Matrix on Beelink GT1 Mini

Hi Everyone,

I’m new on CoreElec. Here my issue today.

I got an old Beelink GT1 Mini, never updated the firmware.

  • Installing 9.2.8 with g12a_s905x2_beelink_gt1_mini_2g.dtb => OK
  • Installing 19.4 rc2 with g12a_s905x2_beelink_gt1_mini and some others => KO. Stock on Beelink Logo
  • Installing 19.4 rc2 with 9.2.8 dtb => Same
  • Updating 9.2.8 to 19.4 rc 2 => Same

9.2.8 seems working fine by the way.

cat /proc/device-tree/coreelec-dt-id => g12a_s905x2_beelink_gt1_mini_2g
cat /proc/device-tree/amlogic-dt-id => g12a_u212_2g

Does Matrix will be compatible with this hardware. If yes, how can I help you ?


Do you use sd card or usb stick?
If sd card then try to boot from usb

If nothing works, then you can try if 19.3 works for you.

Thanks, I tried a sd card will try 19.3 and let you know. I do not have a usb stick for now.

Anyway 9.2.8 is working as expected.

Ok, so I tried on sd card : 19.1, 19.2 and 19.3 same as before. Beelink screen.

I also tried to upgrade Beeling GT1 Mini Firmware with latest and got this error :

Update package verification took 27.6 s (result0)
E: Failed to verify package comptability (result 1): device manifest and framework compatibility matrix are incompatible: HALs incompatible. android.hardware.drm
installation aborted.

Nevermind 9.2.8 is working as expected for my use case. If you need some data or logs from me do not hesitate.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.