Strange CEC effect with Tanix TX3

Hi all,

something strange is happening with my TX3 box: Everytime I turn on the TV and AVR (AVR is connected via HDMI to the box and the TV) the box immediately boots up. I have not seen this effect on any of my other boxes.

I connected my Odroid N2+ to the setup and it behaves like it should (it just does nothing).

I already did a re-install of the TX3 but nothing changes - even if I leave it in a vanilla status w/o any changes.

I am running CE 9.2.6

Any ideas what to do?

Configure your CEC behaviour to your liking. Settings - System - Peripherals - CEC Adapter.

The boxes are configured identically.

Also there is - afaik - no setting that triggers a behaviour like that.

Try to turn off wakeup on active route in ce settings.

I don’t have these CEC settings in the Coreleec menu :neutral_face:

On my box it starts with “Power” and the next point is “Display”.

Only way to solve the issue is to inject bl301:

I did a update on last nightly (9.2 and ce-19) what maybe solve the TX3(G12A} issue. But I can not confirm it does work now or not. Do not use injection from latest CE releases (9.2.6 or 19.0) as it will brick it for sure! Only last nightly do include the fix.

So it’s up to if you feel able to unbrick it if does fail. Khadas VIM3L did also fail after injection and I guess this was related to the same error as it’s also a G12A. If it works on last nightly please do not “downgrade” afterwards to the release as it will update and brick the device again. Do only update to future releases/nightlies.

Or you ask your vendor to solve the issue, what I guess never will be happen.

Great, I will test the nightly tomorrow. Thanks! :slight_smile:

It’s already in nightly so you can just take the last one. Please run the tool with -d or copy after running the tool the console output to get debug prints.

1 Like

Hi Portisch,

I tested quickly this morning with the new nightly, but the behaviour did not change.

What do you mean by “run the tool with -d”? I would switch on the debugging log via the GUI and copy the content after an unexpected boot, does that work as well?

I will do that later today.

-d is a parameter for debug. Do the device still boot after injection? Just run the tool again and post the console debug info.

1 Like

Now it worked, thanks! :slight_smile:

Now I just have to find out, how to wake up my box with the IR remote (because that stopped working). Or is there a way to use a custom code?

By the way:

1 Like
1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.