Stutter Live TV 1080p Playback

I face the same issue with live TV broadcasting in 1080p (TVHeadend). Every few seconds there is an annoying microstutter, I’ve tried several settings including the mentioned advancedsettings in this thread - nothing really helps.

I’ve switched from an old RasPi2 to the S905X (Mediasee N5) today and really thought everything will be much more powerful (as the S905X can play back 4k 60fps) - and I’m a bit shocked. Never had this issue at the same stations on the old RasPi.

If anyone has ideas apart from overclocking the GPU (which I don’t like) … they are welcome.

I did some more research. It’s also happening on 720p TV programs and running the player debug I see every time when a stutter occurs, the “skipped frames” are jumping up a few frames.

So CE / Kodi is skipping frames here, but I have no idea why (I guess I need to read why frames can be skipped and what the difference to dropped frames is). The box is on the wired network and on the same switch as my Raspi2 where this does not happen. So the CE build has the same “physical” conditions as the LE build on the RasPi which plays without these problems.

https://discourse.coreelec.org/t/how-to-report-an-issue-youre-having-with-coreelec/3022/4

@boot2k3 You are right, sorry :wink:

I was able to reproduce a small stutter sequence with 10 skipped frames in 10 seconds, please find the log here:

https://jaycloud.de/f/cc4032a4055846da9e2d/?dl=1

It’s starting from here:

2019-03-05 22:16:24.994 T:4087349168 DEBUG: CRenderManager::PrepareNextRender Frame Skip:4 iter.pts:28.375 lf:3 latency:0.050 Clock:28.398

… until

2019-03-05 22:16:31.216 T:4087349168 DEBUG: CRenderManager::PrepareNextRender Frame Skip:15 iter.pts:34.635 lf:1 latency:0.050 Clock:34.620

It can be much worse with 10 and more skipped frames in a row but that’s what I could reproduce within a few minutes. I hope that helps, otherwise I’m happy to do more tests / logs.

Have you checked the TVHeadend output for continuity errors. Go into the TVHeadend web interface and click on debug button if you get continuity errors it a diver/signal issue.

Yap, no continuity errors at this time. Second, the RasPi plays fine from the same source without microstutters.

I know this is a pretty basic question it looks like your content is 50Hz you do have a 50Hz video mode in your whitelist if you have one? Also does your tv tell you what framerate is being used?

I have a really bad experience with live tv on a S905X (LePotato, current stable and nightly CE builds).
The frame skipping issue really does exist. From what I see this has something to do with deinterlacing because in my case this only happens on 1080i h.264 channels. The skips are rather rare though - usually 5-10 per hour.
Another issue I noticed is that if for whatever reason the stream was stalled or disrupted for a short time - the video will become jerky/stuttery until I switch to another channel or restart the stream.

My other devices (RPi3 and Intel Gemini Lake ITX) don’t have those issues, this seem to be something Amlogic-specific.

I get the jerky/stutter every 2-3 seconds on many channels.

Anyone have any news on this issue?

i had same issue both on netflix and live tv stream with an old kingston class 10 card. Issue fixed with a brand new Sandisk exrtreme pro card.

You have to be more specific. I use live TV every day with CoreELEC and I don’t have any issue.

I used to do it too until 9.02.
Since 9.03 and 9.20 I have the stutter problem on some channels on a KIII and KI pro.

You’re using tvheadend? What’s the information you get on status? Have you tried to change the module drivers to try the one that offers you more stability?

@heliobara I have a KI Pro and I don’t have this problem.
Try the advice of @kos25k.
This may be the cause.
Or try a clean install.

Hi @erbas I just tried both. nothing.
downgraded to 9.02 and everything works perfect. Its a mistery.