Stuttering after pause or black screen

Managed to catch debug log and dmesg log when this happened. Odroid N2+ 4GB Running 19.5 Final

Snippet when this happened exactly. Started the movie, it was stuttering and did a 10sec backwards jump.
kodi_pause_debug_snippet_2023-01-28.txt (521.5 KB)

Full debug log since start

Dmesg since boot

CE-19 is EOSD, try again with clean fresh CE-20 install.

I have had this happen with recent release of 20 also, but I did rollback to 19 because it was more stable.
I think this problem is still worth of taking a look.

Not on CE-19, no.

I’ve seen the stutter start right after the first subtitle line (srt subs) appeared. Before that, just fine. I’ll try and see if it is reproducible in CE-20 as well.

@Boulder, I think your log is better here than in the generic discussion on CE20, so here is the link: CoreELEC 20.0-Nexus Amlogic-ng Discussion - #115 by Boulder
And the quote:

FWIIW experiencing the same with the latest CE20.0 release build on my N2+: if there are subs in the stream (in my case the subs are embedded in the mkv) and the media paused, it starts to stutter after resuming. a -10s jump fixes it.

I’ve had it on 20.1 nightly on a N2. Can’t recall the video it occurred on, but symptoms and fix are exactly as described.

As a complete hack ‘fix’ - can I suggest my addon - - you can use that to automate the jump back after pause (get it to jump back after any pause, and jump back a minimal amount). That should at leat help, functionally speaking, until the problem is solved.


Confirming I also experience this issue on the N2+ on both 19 and 20, micro stutters after pause, the content is watchable but gets annoying.

yeah, i’ve always had this issue on the N2 on core elec leia/matrix, but i usually do a 30s back and then 10s forward (which always resyncs everything) because going back 10s would sometimes still have the stutter. i’ve noticed this on embedded and external subs downloaded by a4ksubtitles. i can post more when i upgrade to THE NEXUS but ain’t no thing.

1 luv core elec 4 lyfe

I had written about this more than a year ago, but the devs haven’t been able to reproduce it, so i started to suspect something else might be causing it. Because while most people have N2, i have GT king pro, so it might not even be the device (at least not the only reason)

Just to check with others this is happening, i am using an LG 4k TV, and also passthrough audio to a Pioneer AVR. Wondering if either of these might be part of the reason. I dont suppose everyone with this problem has LG TV for example?

I have panasonic, and neither n2 or gt king:) So not related to tv,box, avr connection - my box is connected directly with tv.

There are some changes ongoing, so before report test again with latest CE-20 nightly and include a log with best audio/video timing in logging active.

CE-19 logs will not be accepted at all anymore as, it’s final. Upgrade first to last CE-20 nightly!

This is from a fresh build (yesterday). As mentioned earlier, in my case the stuttering starts after the first (srt) subtitle appears, but also after pausing the first time. I think PGS subs do not cause it.

Is anyone having this issue when you disable “allow hardware acceleration - amcodec” under settings → player → videos? When acceleration is enabled the issue happens at all times when playing VC-1 files via 19.5 Matrix RC2 and 20.1 Nexus on my Odroid N2. The issue only happens when pausing and replaying AVC files via 20.1 Nexus (I didn’t notice the pausing issue on 19.5). When acceleration is disabled the issue goes away

Tried with “allow hardware acceleration - amcodec” disabled but then everything stutters :slight_smile: .
Probably because software rendering can’t keep up on my N2+ (ver 19.5).

HOT DIGGITY DAMN, COREELEC! the subtitle stuttering issue is gone for me on a fresh install of 20.1 on a N2!

i can start a video without having to seek forward or back, enable and disable subtitles on a whim without having to seek, change the subtitle, do the subtitle dance, IT’S ALL HERE, BABY!

but for real this rules and the new subtitle engine shaping machine must be doin’ some work. p.s. open sans semi bold around 40ish looks great for not-styled subs. drop that dot tee tee eff in the .kodi/media/Fonts (boy does that capital F matter) and you’ll be cookin’ some good subtitles.


Did a dirty upgrade from Matrix to Nexus 20.1 and the stutter is gone, only got a new issue that sometimes after stopping a video the screen stays black for 20 seconds.

Decided to do a clean install of Nexus 20.1 and now everything works as it should, no more stutter after pause!
Just a little bug that the detailed info screen (the one with bitrate and buffering etc) pushes the subtitles down. This is fixed by stopping and starting the video.

Also ran into stuttering on 20.1 on S905X3 (T95 Max Plus). It manifested in 2 ways, both subtly poor frame pacing with occasional frame skip, and also as described in this thread where after pausing/seeking/using the UI sometimes it would start badly stuttering until next seek.

Nothing interesting in any logs, played with a load of settings, CPU load <10%, and even tried a fresh install on SD card where the issue continued

I ended up reverting to 19.3 which plays back everything perfectly. Sometime I will look further into what would be needed to boot newer Kodi on the kernel from 19.3, which seems to be the golden kernel for X3. A naive attempt at mixing the two fell over badly on boot