Stuttering after pause or black screen

I have panasonic, and neither n2 or gt king:) So not related to tv,box, avr connection - my box is connected directly with tv.

There are some changes ongoing, so before report test again with latest CE-20 nightly and include a log with best audio/video timing in logging active.

CE-19 logs will not be accepted at all anymore as, it’s final. Upgrade first to last CE-20 nightly!

This is from a fresh build (yesterday). As mentioned earlier, in my case the stuttering starts after the first (srt) subtitle appears, but also after pausing the first time. I think PGS subs do not cause it.

Is anyone having this issue when you disable “allow hardware acceleration - amcodec” under settings → player → videos? When acceleration is enabled the issue happens at all times when playing VC-1 files via 19.5 Matrix RC2 and 20.1 Nexus on my Odroid N2. The issue only happens when pausing and replaying AVC files via 20.1 Nexus (I didn’t notice the pausing issue on 19.5). When acceleration is disabled the issue goes away

Tried with “allow hardware acceleration - amcodec” disabled but then everything stutters :slight_smile: .
Probably because software rendering can’t keep up on my N2+ (ver 19.5).

HOT DIGGITY DAMN, COREELEC! the subtitle stuttering issue is gone for me on a fresh install of 20.1 on a N2!

i can start a video without having to seek forward or back, enable and disable subtitles on a whim without having to seek, change the subtitle, do the subtitle dance, IT’S ALL HERE, BABY!

but for real this rules and the new subtitle engine shaping machine must be doin’ some work. p.s. open sans semi bold around 40ish looks great for not-styled subs. drop that dot tee tee eff in the .kodi/media/Fonts (boy does that capital F matter) and you’ll be cookin’ some good subtitles.


Did a dirty upgrade from Matrix to Nexus 20.1 and the stutter is gone, only got a new issue that sometimes after stopping a video the screen stays black for 20 seconds.

Decided to do a clean install of Nexus 20.1 and now everything works as it should, no more stutter after pause!
Just a little bug that the detailed info screen (the one with bitrate and buffering etc) pushes the subtitles down. This is fixed by stopping and starting the video.

Also ran into stuttering on 20.1 on S905X3 (T95 Max Plus). It manifested in 2 ways, both subtly poor frame pacing with occasional frame skip, and also as described in this thread where after pausing/seeking/using the UI sometimes it would start badly stuttering until next seek.

Nothing interesting in any logs, played with a load of settings, CPU load <10%, and even tried a fresh install on SD card where the issue continued

I ended up reverting to 19.3 which plays back everything perfectly. Sometime I will look further into what would be needed to boot newer Kodi on the kernel from 19.3, which seems to be the golden kernel for X3. A naive attempt at mixing the two fell over badly on boot

I’ve been having exactly the same problem described here on my generic (Vontar) 905X4 box. This happens on both 20.1 and 20.2. It doesn’t happen every time I pause, but often enough to be annoying.

Many thanks to @bossanova808 - the unpause jumpback plugin is an excellent workaround.

1 Like


I’m seeing this issue on latest Nexus stable too. Odroid N2+ with eMMC, upgraded from Leia>Matrix>Nexus in space of a day, so not sure where it was introduced.

Have done same with an N2, but not sure if the problem occurs on that one too. Would presume so as performed same process.

Darn i thought i was going mad, but also been having this, On nexus 20.1 and 20.2.

Ways i found to fix, set display hz to 24 in playback.
Or if i add a 0.5s pause on display switching. seems to work.

Bugger only fixes random jumps, stuttering comes back after a pause same as everyone else.

Correction, apologies, i had my tv true motion set to full, was causing skips in fast scenes, all ok now.

1 Like

Yeah, would be nice to pinned that, with big fat letters: “switch off all, of the tv fake magic” :slightly_smiling_face:

Yeah it causes all sorts of issues, i must of been faffing one night and accidentally adjusted it, its as smooth as butter now.

I’m experiencing the same issue on my Odroid C4 on 20.2-Nexus when playing 720p HEVC videos.
I wouldn’t describe it as stuttering, but more like dropped frames (video is not smooth, audio is ok).