Sundtek SkyTV Ultimate - DTV_CLEAR failed [e=Success]

I’ve tried again after 6 months to use the Odroid for tvheadend server.
The Sundtek SkyTV Ultimate still does not work:

linuxdvb: Sundtek DVB-S/S2 (VI) #2 : DVB-S #0 - DTV_CLEAR failed [e=Success]

This tuner was working with Raybuntu’s build, once Coreelec was founded, it never worked again.
It seems that there is some difference between the builds.
I’ve used the sundtek driver from the repository.
The tuner is succesfully loaded:

Jun 22 14:11:52 CoreELEC kernel: usb 1-1.3: SerialNumber: 20140126
Jun 22 14:11:52 CoreELEC kernel: usb 1-1.4: new high-speed USB device number 6 using dwc_otg
Jun 22 14:11:52 CoreELEC kernel: usb 1-1.4: New USB device found, idVendor=2659, idProduct=1502
Jun 22 14:11:52 CoreELEC kernel: usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jun 22 14:11:52 CoreELEC kernel: usb 1-1.4: Product: SkyTV Ultimate 6 2016/Q1
Jun 22 14:11:52 CoreELEC kernel: usb 1-1.4: Manufacturer: Sundtek
Jun 22 14:11:52 CoreELEC kernel: usb 1-1.4: SerialNumber: U170330132547
Jun 22 14:11:52 CoreELEC kernel: usb 1-1.1.1: new low-speed USB device number 7 using dwc_otg

And also the userspace service is loaded and active:

3418 root 0:00 mediasrv --wait-for-devices -p /storage/.kodi/addons/driver.dvb.sundtek-mediatv/bin -c /storage/.kodi/userdata/addon
3419 root 0:00 mediasrv --wait-for-devices -p /storage/.kodi/addons/driver.dvb.sundtek-mediatv/bin -c /storage/.kodi/userdata/addon

I’ve also tried back than to use the addon from Raybuntu’s builds, but it still did not work.
So I assume there must be a difference in the kernel, but as far as I know, only the usb interface is running as a kernel module, the rest is in userspace.

Here’s the discussion about this back then…

Also, everything seems to be working:
CoreELEC:~ # mediaclient -e
**** List of Media Hardware Devices ****
device 0: [SkyTV Ultimate 6 2016/Q1] DVB-S/S2, ANALOG-TV, REMOTE-CONTROL, OSS-AUDIO
ID: 1-1.4
ID: U170330132547
FRONTEND: /dev/dvb/adapter2/frontend0
DVR: /dev/dvb/adapter2/dvr0
DMX: /dev/dvb/adapter2/demux0
VIDEO0: /dev/video11
VBI0: /dev/vbi0
INPUT0: /dev/mediainput0
OSS0: /dev/dsp0

Also seems to be a thread here:


DTV_CLEAR means that the driver has stopped for some reason? I would not know what that could be without seeing the logfiles.
You might check the sundtek support chat and ask for further assistance.

I saw a similar problem on this thread (this was is a DVB-C/T2 tuner) and a member provided me a modified tvheadend client which does not return this error, but still does not scan any mux. It might be also a different problem, I have to check the wriing, but it’s interesting that the H-H dish is correctly positioned, but all muxes are failed when scanning. So for now I cannot confirm that this version of tvheadend indeed works or not.

Unfortunately, the modified tvheadend version is binary only, as it was built by Raybuntu, and the source code is not available any more. Complete discussion here:

I would gladly provide a log, but I don’t know what I could create. In dmesg nothing can be seen, mediaclient locks to the transponder, and tvheadend displays only the error seen above.

If there is some debug switch that I could set, I could try creating some logs.

From what I’ve understood from the discussions is that these builds have the userspace in 32 bit, but kernel is 64 bit, and this created some issues with the tuner.

I’ve created a log file in which you can find both:

  • A the beginning of the log, i’ ve used the modified tvheadend provided on the google link, which seems to work.

2018-11-13 10:49:57 [20863] Starting up Multimedia Framework (Oct 23 2018 12:20:35)

I’ve switched to the original tvheadend server.
In this case, you can see in the log that there are several ‘unknown’ commands issued, which is weird.
Also the e=Success error code is strange to me.

sundtek_error.log (16.0 KB)

Searching for the command from the log, I came across this:

Maybe it’s related.


please contact us via chat.
I know there has been some odd issue around but no one really contacted us about that (and we don’t have such a test-environment here at the moment).
We’re also busy with other new products so it would be nice if you could provide access to your system in order to quickly handle that issue for you.

I would gladly do so. Where can I find this chat window ?

Excuse me, what do you mean no one contacted you? I certainly did and afaik so did @Ray

I think there was a communication issue - or some other problem so we didn’t get through to the actual issue.

The problem is solved now, we’re going to update the driver in 20 minutes.

And yes the issue was a 32bit <-> 64bit data structure issue, we’re just converting them forward and backward as needed now.

Driver is updated. Feedback is welcome.

1 Like

@anon88919003: could you include the updated driver also in the coreelec repo?

Driver can be manually updated from Addon settings. And reboot after that.

A while back we were in contact through your forum with one of mine users. I tried to contact by email and by PM in Kodinerds. I also send and invite for our slack. This invitation still stands, it would be nice to have a contact person from Sundtek in our slack so we can resolve these issues very fast.

Thanks for the fix!

Just keep contacting us if something seems to be forgotten (we’re really busy with new projects & drivers & also the manufacturing process (we’re even doing special software for our assembly line)).

Wow, and here I was having lost hope. Good to hear! Now all I need is some time to set things up again and test this, but that sounds really promising. Thanks to everyone involved in fixing the issue!

As of November 18th, 2018 I can confirm that CoreELEC 8.95.5 with updated addons tvheadend, sundtek media tv and (for good measure) hts pvr client work - no more need for @Ray’s old build! Great stuff!

I just wanted to add, that with some high bitrate channels (using the DVB-S tuner) i"ve notices continuity counter and transport errors.

After some debugging and forums being read, I’ve found that the root cause could be the low USB bandwidth.

I also saw that the HW PID filter was disabled on the ODroid C2, however on the RPI this was enabled.

I’ve changed in the sundtek.conf file (./kodi/addons/driver.dvb.sundtek-mediatv) and now the bandwidh displayed by tvheadend is lower) and there are no more issues.

Maybe it could be ‘defaulted’ to on also for the Odroid C2?

1 Like

It should be an option rather than defaulting it.
Some systems work better with hardware filters, some don’t - it’s not so easy to have generic settings that will be good for all systems.