Support added for S905X2, S922X and A311D!

Thanks for your help. Will give it a try once I get home and confirm.

You can find samples over here ( to test your setup. I’ve tested almost all of the samples and the only problematic are related to 3D MVC and LPCM. So you shouldn’t have any issues regarding DTS and Dolby.

Thanks @Pelican @CI6N0Z looks like my old bluray rips I thought has dolby true hd audio only had dolby digital. I tried test files downloaded from dolby website and all play well.

Only issues I have left now are the always on led light which I understand I have to live with and the issue playing 4k videos which looks like a known issue.

Hi, would you care to elaborate on that? I’m thinking that if that’s the case, there’s really no reason to spend money on boxes with larger rom memory, if you only plan to use it for CE, that is (like me).

Just received my MeCOOL KM9 Pro AndroidTV box (S905X2 2G/16G) and tested with Jul 24 build (the same 16GB SD card upgraded from Jul 22) using g12a_s905x2_2g.dtb.

Boot: OK
Ethernet: OK
Audio: OK
Remote: not OK
x265 10bit 1080p: Play flawlessly
x265 HDR 10bit 2160p: Play OK (checked on 720p TV though, not sure whether HDR color output is correct or not)
CEC: not OK (unlike the X96S TV stick, it reports CEC cannot be initialized!)

WiFi chip on the KM9 Pro is AP6236.

Edit: ‘Tone HDR color to SDR’ under CoreELEC setting is working. I now can get better color for HDR video on the TV.

You have to configure your remote, refer to the thread here.

Yeah, I know. Try to figure out any config file available. I haven’t had that IR remote before!

Edit: Upon update of remote config file, the IR remote is now working. I used M8SProW from repository compiled by bubblegum57. I can power off the TV box with the IR remote but not able to power it back on.

I’m using config from Mecool M8s Pro Plus and power on and power off is working .

hi folks, just bought a new box but not booting coreelec…so I tried the latest nightly, this one CoreELEC-Amlogic-ng.arm-9.1-nightly_20190724-Generic.img
then I copied the device_tree file to the root and renamed it to dtb.img
tried a usb 2 stick, then a usb 3 stick, then I tried the 4gb device tree and the one with 1tb but it gets stuck at boot with a black screen, any ideas?
been using the terminal emulator and ‘reboot update’ cos the toothpaste didn’t work either…

If anyone else got the T95Q you can use this remote config file. Thought this will help someone.

0x14e KEY_1
0x10d KEY_2
0x10c KEY_3
0x14a KEY_4
0x109 KEY_5
0x108 KEY_6
0x146 KEY_7
0x105 KEY_8
0x104 KEY_9
0x101 KEY_0
0x100 KEY_MENU
0x111 KEY_HOME
0x151 KEY_LEFT
0x116 KEY_UP
0x11a KEY_DOWN
0x119 KEY_BACK
0x142 KEY_ESC
0x14c KEY_CONTEXT_MENU # mouse

Isn’t that kind of remote.conf file obsolete after LibreELEC 8 and not used again in LibreELEC/CoreELEC 9?

No. You can use either amremote or meson-ir.

I have the same box and the same issue.
With LibreElec I managed to boot but Kodi crashed on x265 playback with hardware acceleration

Hi! Are there any solutions to open the A95x Max bootloader? Thank!

If bootloader is locked, than no solution…
Need UART boot logs from A95X Max if it doesn’t start from SD card or USB
And also the same for A95x F2

Dear CE team… What choices of the latest technology boxes are possible/recommended if it is an absolute must that I can install to internal or emmc memory?

How to make UART boot logs?

1 Like

Open your box, find the UART pins, solder (or fix with tape) wires to GND, RX, TX, connect them to an USB-serial adapter’s GND, TX, RX pin, connect the adapter to your computer, start a terminal software, setup the connection (115200, 8,1) and power on your box to see the messages.

N2 is still the best choice in my opinion…

tr99 2/16
After the last update the wifi works but the bluetooth does not.
Thanks for the excellent work.