Support added for S905X2, S922X and A311D!

For the last few months users with the Odroid N2 (S922X rev. A) have been able to enjoy using CoreELEC with our next generation releases.

As of today’s nightly release, users with devices containing the S905X2, S922X rev. B and A311D Amlogic SoC’s can now enjoy using CoreELEC also!

The following devices are now supported with our -ng releases.

  • Generic S905X2
  • Odroid N2
  • Beelink GT-King
  • Khadas VIM3

As always work is on-going behind the scenes to further improve our releases and support for Amlogic devices.


S905X2 did seem to be a SOC that was destined to come and go rather quickly on all fronts, so I’m sure that this will give it a boost.

Although not out just yet, is there interest (subject to getting boxes from vendors) to support the S905X3?

Yes ofcourse, that also will be added in due course. :slight_smile:

I just tried my first nightly on a 905x2 X96max box.
It is a 2G/16G 100Mb/s device

It booted
I have wired connection, but not wireless
I configured the remote … had the files saved for this remote
I have a Digibit R1 and a HDHomerun connected to a Tanix Tx3 running CE and Tvheadend and serving client devices.

I installed the Tvheadend client on the nightly and all channels I have checked so far have worked well.

My needs are simple … this is just for watching TV channels and a few stored videos.
There is no fancy audio or AVR or UHD TV involved.
Just a standard 1080 TV and two speaker sound.
Presently I am using a 1080 monitor for testing.

NEGATIVE: This image will not boot from the SD card slot in my STB. But the same card, in an SD to USB adapter, boots fine using the USB3 USB slot.

As it stands this image would appear to cover my use case for it, completely.

I received a UHD satellite test TV channel without problems and it displayed correctly on the 1080 monitor. It used HW decode and one CPU core was about 30% while the others were generally around 5% use.
Of course it has only been a few minutes testing, so that view could possibly change as development takes place.

Congrats to the dev team … I am really happy this box can now run CE! :smiley:

1 Like

Nice. I was just looking at the X96 Max on eBay and Amazon. I think I’m going to go with that box and put CE on it.

I am in your same situation but my remote does not work. Can you help?

I used the meson-ir means of enabling the remote.
It works well but have a couple of adjustments to make to include all buttons of remote.

Thank you. Unfortunately I am completely ignorant in these things as ssh etc. too difficult for me. I would like to have a file to put somewhere and have my remote working. Thanks again and apologise for my zero knowledge

pls can you post your config file and tell me where I shoul put it?

Are you using a S905X2 based X96 Max box?

Yes 4g ram and 32 g rom

You can add the files using SMB.

In Configfiles put file named rc_maps.cfg with a single line
meson-ir * 905x2keymap

In Configfiles/rc_keymaps put the file with the button functions you wish to apply.
This file to be named 905x2keymap
(name matches the entry in first file)

The content of the 905xkeymap file I am presently using follows

# table 905x2keymap, type: NEC
0x101 Key_0
0x14e Key_1
0x10d Key_2
0x10c Key_3
0x14a Key_4
0x109 Key_5
0x108 Key_6
0x146 Key_7
0x105 Key_8
0x104 Key_9
0x147 Key_SUBTITLE
0x142 Key_DELETE
0x159 Key_VIDEO_PREV
0x158 Key_VIDEO_NEXT
0x111 Key_HOME
0x14c Key_INFO 
0x151 Key_LEFT
0x150 Key_RIGHT
0x116 Key_UP
0x11a Key_DOWN
0x113 Key_ENTER 
0x100 BTN_MOUSE 
0x119 Key_ESC 
0x118 Key_VOLUMEUP
0x1f2 Key_ChannelDOWN
0x143 Key_MUTE 
0x1f1 Key_EXIT 
0x1f4 Key_O
0x140 Key_POWER 

The @ key is assigned to Subtitle on and off.
The TV volume controls assigned to Channel Up and Down.
The Set key is not configured (or operational?)

This is just my initial attempt and can change of course, and you can alter any button assignments for your use easily.

Thanks a lot. Still very confused on what I should do. If you could just post a ready-made config.file and tell me where I should put it, this will be really appreciated and helpul for me. Thank you again.

I do not use any other operating system other than Linux so I cannot be more specific than I already have been about creation of files in the correct format etc etc. Maybe someone else can help in this regard.

I have already specified where to put the file.

From what are you booting this? … USB stick or SD card?

Is your wireless working?

That is ready-made config file with clear instructions where to put it.
Read it again.

I am booting from SD card put in USB adapter using the USB3 slot. Just as you. It does not boot from SD card in STB. My home wireless is working .

Thank you for that information.
Hopefully for wireless on my device it is just a driver not included.
Also it seems when the problem is found for the SD card boot it should correct both devices.

If you can do it, or find a teardown of this box and take a picture of the Wifi chip, that would help.
It’s likely that a driver is simply missing.