Support added for S905X2, S922X and A311D!

You can try different sd card.

I see an issue with some dolby digital audio playback. When I check the audio settings, I can see the audio is displayed as AAC 5.1 6 channel, but it passes as PCM 2.0 to the receiver. I tried to get the file playback related info, but that’s blank.

I tried playing the same file on LG webos and it outputs dolby digital 5.1. I tried setting the speaker layout in coreelec audio settings to 2.0, 5.1 and 7.1. With 5.1 and 7.1 video stutters a lot, but still plays as PCM 2.0.

The issue happens only with some files.

CE doesn’t support LPCM on the 4.9 kernel. This has been discussed numerous times already.
Set channels to 2.0 and enable AC3 transcoding.

Thanks. That worked.

1 Like

H96 Max X2 (S905X2 4/32g) Android DTB


H96 Max X2 (S905X2 4/32G) Android remotecfg

1 Like

Thanks TNS. I was not able to get anyware :+1:
Hopefully thecoolest can use the H96 Max X2

I don’t have a usb wifi adapter . If @TheCoolest can help us getting the wifi or ethernet working then I can ssh into the box and try to create a remote.conf from scratch.

this is the box and the remote I have.

1 Like

After @Pelican reminded me that both amreote and ir-meson work a couple of pages back, the stock remote control of my X96S TV stick works again. WiFi on that device is not working yet, and there is no Ethernet (obviously because it’s a TV stick). I just copied the remote.conf to the root directory of microSD card and that’s it, no need to use SSH and go through those procedures.

Your H96 Max stock remote looks very like a MeCOOL remote. You can try the remote.conf file for X96S I uploaded a few posts back and see if it works.

1 Like

Dude it works!!!
Thanks man. One More Hurdle crossed.
With a little help from our devs we will get there.

If your device doesn’t boot then your either using the wrong image, device tree or haven’t pressed the function button before your first boot.

If Ethernet is not working then you have picked the wrong device tree.

If your remote doesn’t work then this is because you haven’t configured your device for it, our images do not work with any remotes out of the box.

If wifi or bluetooth doesn’t work then message me directly as the driver or firmware is likely missing for your device.

1 Like

Good, have you asked me if it is possible to support wifi the mecool km9 ? Your wifi is the IT6335

@wkchick
Remote file works good in H96 max X2 :grinning: as per your instructions above.
Now hopefully someone smarter than me can work out how to get networks up

@SamWilson @bazzle read my previous post.

@adamg
I am using the DTB recommended from within download for my box, same as the other posters with H96 boxes above. I tried other DTB but @the coolest asked for an original DTB from the H96 box.
@TNS has posted this file above for him to have a look at.

[Pelican)CoreELEC Team
@bazzle:
Try to use g12a_s905x2_4g_1gbit.dtb
This is the one I am using that allows Corelec to Boot, :+1:

OKAY Guys & Devels
X96 Max S905X2

CE nightly build 20190725
2160 60p gui - OK
4K HW H265/HEVC - OK
1G Ethernet - OK
WIFI 2.4/5GHz - OK
BT - OK
IR Remote - OK

Is it a H96 Max X2 or H96 Max?
I’m lost between all those different models. One works, the other one doesn’t. Makes very little sense to me.

@TNS I looked at the DTB, but couldn’t really see anything that stood out to me.
I think the only way to find out why it’s not working is to provide us with a dmesg log.

1 Like

H96 Max x2
Found this post #1005 on Libreelec forum re no Network.
Dont know if its of any help?

Quote
“Need to edit (env.ini). You can ignore the Mac address error.
Where it’s at? What edits do I have to perform ?
Upd. Solved the problem with ethernet by changing the dtb line to x96maxrmii in both extlinux and uenv.ini also.”
)https://forum.libreelec.tv/thread/12330-test-libreelec-images-with-kodi-18-for-s9xxx/?pageNo=56)

it’s X96 Max vontar
4/32
1G Eth
WIFI 2.4/5
Bluetooth
all is working, but I not test digital sound because no subj…

ps. and more. CEC isn’t turn off my tv why?

1 Like

Locking this thread as it has grown beyond the scope of the announcement.

If you require help with a particular device then open a thread in the correct sub-forum.

2 Likes