Switching off with the power switch?

I’ve tried searching through these forums, but to no avail. My hardware is Minix NEO U1 (S905.arm) with CoreELEC 9.0.3 and Kodi 18.3. The remote control power switch boots the system up fine, but does not shut it down: one has to go into the power menu and manually select shut down. This used to work on my earlier set of LibreELEC 8.2.3.1 and Kodi 17.6. Is there some option somewhere to activate shutting down with the power switch?

Enter via SSH and send this command:

echo “meson-ir * minix_neo” > /storage/.config/rc_maps.cfg

then reboot

Having the exact same issue here with my Minix U9-H and Minix A3 remote.

Excellent, this adds power key shutdown functionality to both the infrared remote control and the Minix Neo A2 Lite radio remote. Thank you!

A caveat for anyone directly copy-pasting the snippet @Blakey gave above: this discussion board seems to replace normal ASCII quotation marks in text with UTF left and right quotes so the unquoted asterisk will be subject to file name expansion by your shell. This of course won’t work, took me a moment to figure out what had happened. This seems to happen to apostrophes too. Who else hates “smart” quotes?

Hi people

I’m a newbie about N2, Linux, editing config ini file etc. I followed guide for IR remote wakeup code but couldn’t success about it. My Minix remote doesn’t turn on or off my N2. I connected to n2 with putty on my computer, send necessary commands and recieved remote code on computer and after that tried to add that code into ini file but because of I’m not sure where exactly (at the end, or at the top of ini file…) it didn’t worked.

On kodi forum guys adviced me to install the -ng nightly .tar update also. I guess I will again face with the same difficulty about editing config file, so I really need to learn how to do it. Can you please suggest me a walk through with screenshot or a video about how I need to open, add, edit and save config ini file?

Thank you

How would I do this for my Beelink GT King, power on works fine but I can’t power off

This broke for me after updating to CoreELEC 19. My /storage/.config/rc_maps.cfg still says meson-ir * minix_neo

Power on still functions well with remotewakeup="0xE718FE01" in /flash/config.ini

Please add .toml to the name of the remote.

1 Like

This worked. Thanks a lot!

1 point to Vasco. :smiley:
Thanks

1 Like

About | FAQ | Terms of Service | Privacy Policy | Legal Notice