T95Q - the case of the missing BT / WiFi

Hi there
First of all - thank you. What a wonderful relief it is to boot my device from an SD card and to see videos run smoothly, 3D communicated correctly to the TV, and overall it seems so stable. Well, if I can exclude the connectivity issues.
I run the nightly of 4/9/19, and to my surprise (using the g12a_s905x2_4g_1gbit.dtb as dtb.img) it finally started the wireless, and yet it didn’t manage to pass the negotiation phase, didn’t even arrived to the password if I recall.
So I rebooted. And then I had no network. So I tried again. Nothing. try loading with the g12a_s905x2_4g.dtb as dtb.ibm - dead. tried to re-image the SD card and start from scratch - still don’t see anything. Sadly I can’t run wire to the router, but at least with the g12a_s905x2_4g.dtb it identified the network card - which was nice if I could use network cables where the streamer is located.

So… please advise the steps I need to take in order to help you identify the problem, and again - thank you for the amazing work you’re doing!

Reboot the box, make sure it’s connected to the internet, and run the following commands in SSH:
dmesg | paste
udevadm info /sys/bus/sdio/devices/sdio* | paste
Then reply with the URLs you get back from those commands.

You can move it close to the router for this procedure.
Another way would be to open up the box to see what wifi chip it’s using.

If they are still using the same original board it’s the AP6255.

AP6255 already has a driver in CE, so it should work without issue.

Here you go:

and for the second command, I got this:

CoreELEC:~ # udevadm info /sys/bus/sdio/devices/sdio*
Unknown device “/sys/bus/sdio/devices/sdio*”: No such device

As you can see I’m using external WLAN adapter…


Here you go:


and for the second command… this is what i get:
Unknown device “/sys/bus/sdio/devices/sdio*”: No such device

Using an external wireless module, as you can see… EW-7811Un

  1. With WIRED connection:
    and again the same:
    Unknown device “/sys/bus/sdio/devices/sdio*”: No such device

I presume that WiFi and BT works in Android?

You read my thoughts :smile: and yes, it does. According to Android (Amlogic TV Box Tool) the WiFi info is as follows:

Manufacturer: Realtek
Type: RTL 8822B

I’m not sure why CE isn’t picking up your Wifi or BT.
We have both RTL8822BS and RTL8822BU drivers included in the builds.
Could be a dtb issue.

I decided to open the box and take a look at the chipset.
Surprisingly (or not), the manufacturer had decided to scrap all the information from the chip RF metal shield, so it’s a blank mystery at this stage :smile:

According to android and the MAC address I get (which starts with: 38:83:9A) this leads me to to assume this is the manufacturer:

On their website the only thing that comes close to how the “blank” RF shield of the chip looks inside is this:
which seems to use MTK 7601

in dpemg on the android I got this:
[ 13.655065] <6>[ 13.655065@1] rtk_btusb: RTKBT_RELEASE_NAME: 20190311_BT_ANDROID_9.0
[ 13.655834] <6>[ 13.655834@1] rtk_btusb: Realtek Bluetooth USB driver module init, version 5.0.1
[ 13.663363] <6>[ 13.663363@1] rtk_btusb: Register usb char device interface for BT driver
[ 13.670787] <6>[ 13.670787@1] usbcore: registered new interface driver rtk_btusb
[ 13.745613] <6>[ 13.745613@3] read descriptors
[ 13.745652] <6>[ 13.745652@3] read strings

which is again darn confusing.

When you opened the box did you take a note of the board reference information?

There is usually a revision number, which might have mention elsewhere on the web.

These are a couple of examples from a T95Q

Thanks man for the tip! The white sticker in my board states the following:

Oh, and by the way - the communication card is soldiered on the other side of the board, and now I see which chip it is:


Module model:RL-SM02F-8822BS-V3.1
Product description:WLAN 11a/b/g/n/ac SDIO module
Main chip:RTL8822BS
Wireless standard:WIFI: IEEE802.11a/b/g/n/ac
BT : V4.1
Data transmission speed:1,2,5.5,6,11,12,18,22,24,30,36,48,54,60,90,120 and maximum of 433Mbps
modulation mode:2.4GHz /5 GHz +BT
Operating system support:Windows 2000,XP32-64,Vista 32/64,Win7 32/64,Linux, Android
Bus interface:WiFi: SDIO
Work channel:WiFi 2.4GHz:
United States :11: (Ch. 1-11);
Europe :13: (Ch. 1-13) ;
Japan :14: (Ch. 1-14)
BT 2.4GHz: Ch. 0 ~78
working voltage:3.3 V ±0.2V I/O supply voltage
working temperature:0 ~ +70° C ambient temperature
Storage temperature:-40 ~ 125°C ambient temperature
humidity:5 to 90 % maximum (non-condensing)
size:15x13 x1.6mm (LxWxH) ±0.2MM

If you manage to extract the original Android DTB file, maybe it’ll help us figure out why it isn’t working for you.
It looks like CE doesn’t pick up the wifi or bt controllers at all, and we already have a RTL8822BS driver included, so I suspect a DTB issue.

Thanks - here’s a link to the dtb.img

Well, at least the one from the firmware OTA…

I tried to copy the file from the android OS, but it gives me a 256KB file size and when I looked at it size in \dev it was a size of zero…
In any case here’s that file

Can you try CE with this DTB?
g12a_s905x2_4g_t95q.dtb (70.8 KB)

Hi there, thanks for the dtb.

copied to the SD card, deleted the dtb.img, renamed the file you provided to dtb.img, restarted (this time with no external WLAN). results: network adapter works, but not WLAN. did a full reset - nothing changed. Wireless network not detected :frowning:

Taking a look at your Android dmesg log again (thanks adamg :slight_smile:) it seems that the chip is connected to via USB rather than SDIO, and our RTL8822BS driver is compiled for SDIO mode only, that’s likely why it isn’t working.

Can you post output from lsusb?

Here you go (using wireless USB module connected to an external USB 3.0 hub):

Bus 002 Device 002: ID 05e3:0616 Genesys Logic, Inc. hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 1997:2433
Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Can you do it without your USB wifi card?