T95x2 remote config trouble (s905x2)

Hi All,
I have the sidiwen t95x2 with help of adamg have got it almost working right, the only issue i have now is the remote.

Using CoreELEC-Amlogic-ng.arm-9.1-nightly_20190806 at time of scanning for keypresses.

Went through the posts and found the how-to and did following from putty shh client:-

systemctl stop kodi
systemctl stop eventlircd

Next scaned for the IR codes with

ir-keytable -t

recording hex code as key pressed, then associated those code with kodi key maps for remote and saved results to 1, t905x2_remote and 2, created rc_maps.cfg with meson-ir * t905x2_remote.

The next day used putty again to do following:-

copy t905x2_remote to /storage/.config/rc_keymaps/

then copied rc_maps.cfg to /storage/.config/

the rebooted, on reboot coreelec updated to CoreELEC-Amlogic-ng.arm-9.1-nightly_20190808

but remote does not work now, tried steps to record key codes as above only to find the box nolonger responds to the remote, however if you add -u after ir-keytable -t it respond with codes as described in the bl301 injection for wakeup.

anyone have any ideas on how to fix?


1 Like

The same happens to me. With the same tvbox.

yes, not working for me too

Please enter remoteinfo on SSH and paste the link.

1 Like

Here you have: @anon88919003

1 Like

Your missing the top line in /storage/.config/rc_keymaps/t95x2 which specifies your remote table name and type.

Go back and read the guide again and look at the example file.

1 Like

It already works correctly. I leave the remote here (meson-ir), for those who are interested.
t95x2_Fix.zip (1.0 KB)

1 Like

Well i’m stumped, rechecked my files and locations they were ok, only difference between mine and sams was our mapings (i mapped the blue tv buttons) and still no joy with the remote.

anyone got any suggestions?

Nobody can help you if you don’t follow the instructions that I previously gave you.

Hi Adamg, http://ix.io/1Rt3, heres mine

Missed the request for remoteinfo from you

Your remote config looks fine but there was an issue with the 0811 nightly with IR, try the latest one.

adamg, CoreELEC-Amlogic-ng.arm-9.1-nightly_20190812, updated on boot, and still no go.

During update new line appeared after system install 100% saying something about device tree and bl injection for the wakeup, went by too quick to read.

Went back over process, and redid stop kodi and eventlirc, issued ir-keytable -t but no response on any remote button pressed, however if I add -u also, I get this response from every button pressed on the remote: irmp code remotewakeup=‘0xb44bfe01’, decode type=‘0x0’, remotewaeupmask=‘0xffffffff’.

will also try 0813 when it arrives


this isn’t possible as the “autoupdate” is not included before 0815.
Please run tomorrow again the inject_bl301 tool, than it will continue with autoupdate of the bl301 in future

Hi Portisch, I talking about auto update for coreelec, all i can report is what I have seen and definitely did see mention of the wake up, from memory the updates of coreelec, new update found, new update downloaded, do you wish to install?

box reboots reports .tar found, unpacks then install kernel then system, finds the g12a 4gb dtd, either before or after, the a couple or so lines , then mentions something about compatable? device tree and bl301, but I have seen these bits during coreelec update since nightly 20190806, next update i will video the process and verify wording


It’s not possible as I pushed the bl301 autoupdate 0813!

Sorry portisch, my snafu I’m afraid, misread and joined several lines from the reboot, as they went by so fast, caught the end of enabled and interpreted it as bl30… along with ‘remote toggle’ which enforced the on/off link with the remote wake up, device tree, was the locate and copy of meson-g12a-4gb-dtb.

the new? lines I saw and mistook were after the boot files line, in image attached.


The install had had update from 0803 to 1408, so reformatted and fresh install of 1608 nightly with remote config and keymaps, adam said were ok, but still no joy the supplied remote still does not work, ir-keytable -t with kodi and eventlirc stopped still displays nothing, but ir-keytable -t -u, returns the remotewakeup codes as previously described.

on side note, tried briefly LibreELEC-AMLG12.arm-9.80-devel-20190724161814-893dd58-s905x2, and remote works in that, but not LAN, but prefer coreelec so went back to it.

Again my apologies

You have to read the guide about the IR again:

Use ir-keytable -p NEC,RC-5,RC-6,JVC,SONY -t. You have to set the protocol(s), otherwise nothing get decoded.