Tanix TX3 (s905X3), "can not mount /dev/CE_STORAGE" after eMMC installation

Hello all,

I got a Tanix TX3 box (s905X3 CPU, 4GB RAM, Gigabit LAN). Everything worked fine when I ran CE 19.2 RC2 from mSD card or eMMC with dual boot configuration. I used the sm1_s905x3_4g_1gbit.dtb file.

As I never use Android, I decided to convert my dual boot config to single boot. There I had problems. Ceemmc finished “successfully” but at first boot the system halted with the message “can not mount /dev/CE_STORAGE”

I repeated the process, ceemmc found a previous installation and I selected to renew it with “data from current used SD or USB device”
This time I caught the following error:
mount: mounting /dev/loop2 on /media/CE_STORAGE failed: Invalid argument
but cemmc finished with “Success!”

Upon reboot, I got the same error message: “can not mount /dev/CE_STORAGE”

Here is the dmesg output after the last installation attempt: http://ix.io/3uOB

Is there a way to solve the problem without reinstalling Android?

No, flash Android and use dual boot.

Is there a hardware incompatibility that prevents a proper single boot installation?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.