Tanix X4 / S905X4

Hi there - mine is Tanix branded with a Tanix logo on the case.

Mine too but only with a 100Mb Ethernet port i.e. no gigabit LAN port !!!

I just got a Tanix “labeled” box today and it is only 100M in Android but advertised 1000M on Amazon.

It is quite obvious, that there is a force in the universe, that is preventing you from acquiring an Android box that has gigabit Ethernet capabilities.

I am only trying to future proof myself for the new kernel since my odroid and vim devices are so much better with CE anyway.

My flavour of the Tanix X4 though is not the way to go, the TF card is hard to access, plus it is upside down like the other ports. No wifi or BT either. Don’t know about the coax SPDIF but I will return this. Their Android (ATV) doesn’t even allow network adb connections

A lot of these devices have ‘upside down’ HDMI and USB ports. The OSMC Vero 4K is very similar in that regard.

Certainly it’s preventing me from getting one. A USB 3.0 Hub with built-in Gigabit Ethernet is probably the least-worst solution I guess. The Tanix is a lot ‘subtler’ than the X96 LED light-show fest.

Anyone got any tips on opening a Tanix X4 - I’ve tried plastic plectrums around the seams in the base, and it doesn’t look like the four plastic feet come out to reveal screws?

I am sure superCeleron on the Freaktab forum, can answer that question.

@noggin just work your way around with a plectrum, mine opened easily that way.

Yep - got in to mine that way eventually!

There is an H1102NL magnetic that is 10/100Mbs only by the Ethernet connector - so that’ll be one indicator as to why mine is 100Mbs-only and not Gigabit. (@hubula yours has the same model of magnetic by the look of it so is also 100Mbs only?)

Yep only 100Mb chip on mine too.

Just got this box. Also have only 10/100Mbs. On CE, Nexus 20, there is no Wifi or Bluetooth. Also, when put box in suspend, it fully shuts down the box. But when it is powered off by the TV / CEC, it does go into suspend/sleep, and wakes without a full reboot.
Otherwise, TVh and all other options work like they should. Thank you.

Testing HK1 and A95XF4
Not Tanix

However was having similar issues every time i changed input/source on monitor Box wound wake up…

So i have disabled CeC in CoreELEC.

Now no issues

From Kodi ui/interface


Disable CeC adapter

Box also powers down/up
No issues


Did you manage to get CE running on your box?

No, not to any satisfactory degree.
I intended to use it mostly for live TV (via tvheadend running in a server box), but the display is not cooperating. It pauses with wee circle doing its thing on screen. No wifi or BT but those I would not be using so not a deal breaker.

I have not tried it recently as I have a few other projects on the go which take precedence. Maybe there is something in a recent release that improves matters?

I have a Tanix TX3 S905X3 that I’ve been happy with and am looking for a TV Box for another room. I should just buy another one of the older model since it’s been solid with SlimBox and CE.

Tanix4-vfd.conf (1.2 KB)
This is the vfd file i use, based on input from here and elsewhere. Not perfect, but gets the time.

1 Like

@sabre6 Thanks for the VFD file.

Tonight I used the ‘ne’ release and the VFD file and the Tanix X4 is up and running.
No BT and no Wifi but ethernet working.
It appears to take longer to switch between channels than other boxes (S905x3) with older images.
As I have only just imaged this I have no real info, except that it does now play the TV channels.

Thanks, I was hoping ne would activate BT and Wifi.