Tanix X4 / S905X4

Guys how i can use emmc in this box?I don’t need android, i need single load to coreelec from emmc. Maybe someone can help and i can implement it?

Click this link and keep reading till you see it.

1 Like

Thank you i see that it’s not support maybe I can mount userdata partition to coreelec. I have one path that i want to use emmc storage.
Maybe this dtb will help https://drive.google.com/file/d/1F_Wo2F9n9_-fbGJrsGIRHGexQIYt3jKZ/view?usp=share_link

Once released to the public, Amlogic-ne will support migration to emmc.


But it will no support kodi?

What makes you think that? CoreELEC is a ‘Just enough OS’ (JeOS) Linux distribution based on Kodi technology for popular Amlogic hardware.

I read this. Or will be import another version?From link you give me

CoreELEC 20 (both projects ng and ne) is based on Kodi Nexus.

1 Like

Guys how I can see that CoreELEC 20 ne is released? I google a little and didn’t find information.

1 Like


I just bought this Tanix X4 box 4g, I boot coreelec but no wifi.
I have no idea where I can fix that.


Wait a new version of coreelec

It’s work with the update: it’s magic :smiley:

Using the ne build with Nexus 20 RC2. Wifi now works - thank you. Bluetooth does not yet seem to work.

Trying to install to eMMC, there is only single boot option right now, no dual boot option.

Hi guys find two bugs with version 20. build

CoreELEC (official): 20.0-Nexus_nightly_20230115 (Amlogic-ne.arm)
      Machine model: Amlogic
     CoreELEC dt-id: sc2_s905x4_4g

First doesn’t work /usr/sbin/fw_setenv bootfromnand 1 (if you need to switch load from sdcard to emmc memeory). When i run command and reboot box tanix freeze in logo.
I fix it to change (but i think it’s too much))))
/usr/sbin/fw_setenv bootcmd 'if test ${bootfromnand} = 1; then setenv bootfromnand 0; saveenv; else run bootfromemmc;run bootfromsd; run bootfromusb; fi; run storeboot'
And return it to
/usr/sbin/fw_setenv bootcmd 'if test ${bootfromnand} = 1; then setenv bootfromnand 0; saveenv; else run bootfromsd; run bootfromusb; run bootfromemmc; fi; run storeboot'

And second problem with
kodi-send --action='PlayMedia('/storage/music/test', isdir)'
Doesn’t work, i get this logs:

2023-01-15 16:30:40.588 T:1177    error <general>: GetItemsForPlayList: Unable to get playlist items for /storage/music/test
2023-01-15 16:30:40.591 T:1177     info <general>: VideoPlayer::OpenFile: /storage/music/test
2023-01-15 16:30:40.592 T:1398     info <general>: Creating InputStream
2023-01-15 16:30:40.592 T:1398    error <general>: CVideoPlayer::OpenInputStream - error opening [/storage/music/3-Sunset]
2023-01-15 16:30:40.592 T:1398     info <general>: CVideoPlayer::OnExit()
2023-01-15 16:30:40.625 T:1177     info <general>: CVideoPlayer::CloseFile()
2023-01-15 16:30:40.631 T:1177     info <general>: VideoPlayer: waiting for threads to exit
2023-01-15 16:30:40.632 T:1177     info <general>: VideoPlayer: finished waiting

I see that error was a long time ago with matrix i think, maybe it will be helpfull
[video][PVR] Feature: Continue watching TV shows, seasons, movie sets and PVR recordings folders by ksooo · Pull Request #22107 · xbmc/xbmc · GitHub.

Thank you and have a nice day!

Hello I have a strange problem with Tanix X4 4GB-32GB. I have installed Coreelec Nexus 20.0, the version for Amlogic S905X4 - Amlogic-ne and use the device tree file sc2_s905x4_4g and manage to launch it on the TV Box. Here the issues have started

  • TV is not working fine for me. I am using TVHeadend and Simple PVR clients and I have quality issue with the picture. If I play something from Youtube or movie the picture is fine. I have only issues with TV. I changed the HDMI cable still the same, ports on TV still the same
  • I installed the CE on a new card - but I can not launch it on the TV Box. The Box is not recognizing it - I am using the dtb.img file from the first installation and tried to use the fresh file from the device tree but can not launch the new installation

Can you help me and advise me what to change in the settings for TV in order to improve the picture OR how to make a new fresh installation and what dtb file to use to check if the problem will be resolved?
Thanks in advance for your support!

Problem solved - the reason was due to the hardware acceleration from the video settings

Limit colour depth in expert display settings, like to 10 or 8 bit

it is not due to the color depth. On YT is working fine
looks more like wrong frequency or wrong codec but I do not know