Technical question regarding LE<->CE switch

It would be good if you posted back your experience of this and how it compared with what you previously understood.
No doubt there are others with the same dillema.

The reason for why they are so strict regarding this is that they support install to eMMC. If you for instance have installed CE to eMMC and later want to install AltLinux, ArchLinux, Armbian, LE, Manjaro etc. to eMMC, you will likely have issues. One should think that burning Android back to eMMC and example toggle “full erase” would solve this, but unfortunately sometimes it doesn’t and the only solution is to wipe eMMC completely before a new installation.

If you plan to example use Android/LE/Armbian/etc on your eMMC and boot CE from a SD card or USB whenever you want, this shouldn’t be an issue. Regardless, let us know when you have tested this further :+1:

My experience is as follows:
I have a x96 max (s95x2) and I had CE installed on a sd. I wanted to try LE with kodi 19 alpha and it started. I put CE in the sd again and it also started. The problem is now I can’t start the tvbox with the remote. So to recover the start-up again with the remote control, do you have to put the stock or is there any other solution?

That is strange, unfortunately I cannot tell you why this could have happened. Have you tried to boot back in android and redo the “ota/reboot update/toothpick” to boot in CE?

You could try to use remote.conf file for you remote. It possible will fix your issue

@miankel please do not hijack threads, this thread is about switching between CE and LE.

There is plenty of threads regarding the issue of not being able to wake from standby which is not related to the topic of this thread.

So basically the autoscript is being loaded by the vendor uboot when triggering recovery mode and the env from the autoscript is merged with the original env?

And then when booting, the vendor uboot boots CE uboot and this then loads the kernel and the kernel loads busybox?

@quta you got it almost exactly right except CE does not bundle a custom uboot except for C2/N2/LePotato.

When you press the reset button during bootup then recovery mode is initiated and during that process the bootloader searches external media for aml_autoscript.

In aml_autoscript we first tell the bootloader to reset the enviroment partition back to its defaults and then to load our kernel and dtb and to always attempt to load them from external media first everytime the device boots, this is then saved to the environment partition that uboot reads on every boot up.

It sounds more complicated than it actually is but needless to say aml_autoscript is only read and its contents executed when that button is pressed.

You only have to do this once each time you switch to whatever OS you choose to run and if your running CE from external media then you most certainly do not have to reinstall Android and lose all your data.

@anon88919003

A pity that it cannot initiate this process even in a hard reboot (Removal of the plug from the electricity) if my device does not have a reset button and or android.

This is just 1 of the reasons that we advise users against using installtointernal.

I believe there is a way to force aml_autoscript to be re-read on reboot but I can’t remember it from the top of my head, @Portisch may have the answer.

When booted in CE fw_setenv upgrade_step 3 in a SSH connection and reboot. On the next boot the aml_autoscript will get executed. I don’t know if the command is included at LE/Android.

Or u run the aml_autoscript directly:

dd if=aml_autoscript bs=72 skip=1 status=none | while read line; do cmd=$(echo $line | sed -n "s|^setenv (.*\)|fw_setenv -c $SYSTEM_ROOT/etc/fw_env.config \1|gp") [ -n "$cmd" ] && eval $cmd done

Untested, I don’t know if this works on SSH connection.

Edit:
I also never tested it but I guess when in Android and execute reboot update will also re-read the aml_autoscript file from SD/USB.

And u are sure your box does not have a reset button? Sometimes the button is hidden in the audio jack. Use a wooden toothpick and try it.

Thank you for the information, I’ll try those commands via the SSH connection in the LE in installtointernal. I have Scishion V88PRO and nowhere I could find the reset button or in the audio jack.
Installed the I LE into the installtointernal a long time ago when it was LE 8, now I know that it was vain and silly. :frowning:
But it is interesting that LE me to the SD card it goes to install, will boot me without a problem.

It seems that a toothpick in the AV when booting should reset.

Shoog

No, I tried many times, it is not there.

Scishion V88PRO indeed has no switch, but there are other options. Checkout
https://translate.google.de/translate?hl=de&sl=ru&tl=en&u=https%3A%2F%2F4pda.ru%2Fforum%2Flofiversion%2Findex.php%3Ft778043.html
What happens if you power on with PC connected to USB4?

For firmware from an IMG file, use the USB Burning Tool 2.0.7 - instructions .
Important points:
There is no Reset button in this model, it is enough when the power supply is turned off, connect the box to the rear USB-4 port to the PC with a USB-male / male cable and the box will be immediately detected in the USB Burning Tool in Connect Success firmware mode.

I had to try. This is for me the new information and thank you for the info on the link.

Hi!

Unfortunately none of these methods are working on my GT-King. I’ve tried the reset button, the Reboot to Libre APK, the restart upgrade command from terminal, but no success. I’ve tried many Linux distro. Sometimes only a black screen, sometimes just repeated reboots.
I’ve tried LE, but just reboots only.
I’ve upgraded the firmware from an SD card in OTA mode. nothing changed.

But the CE boots every time with every methods.

Do you have any idea what can be the problem? I do not want to reflash the unit and reinstall every app…

LE and CE is not compatible, reset of the Android (bootloader) is needed.

I’ve got this but how do I do this without reflash?
It was mentioned that the three reboot option can repair the bootloader, but they are not working for me. Does anyone have any clue why?
How can I check what is happening during boot? How can I be sure that the aml_autoscript was executed and done the repairing?
Thanks in advance for any advice.

Type in bootloader console:

devenv
saveenv