Tencent Aurora 4 Pro

Using the Coreelec system, version CoreELEC Amlogic ne. aarch64-21.1 Omega Knightly_20240623 Generic. img. gz, when playing Dolby Vision, there will be 4k Dolby Vision flashing and sound stuttering at 50Hz or 60Hz, and the sound will stutter one by one.

Tencent Aurora 4 pro box currently uses the latest coreelec ne 21 nightly version. I modified the dtb file and found a dtb file and copied it to the root directory of the USB disk. It works normally

After research by my netizens and I, we have solved the problem of dtb gigabit wired and wifi including bluetooth. In addition, we have also solved the prompt that the kernel version of dv is too low. I hope the official @Portisch can test the dtb file I modified. I am It is modified based on ugoos’ dtb. I will post the log later this evening. Please take care of it when you have time. Thank you.

dovi.ko (1.5 MB)

ugoosAfter modification-dtb.img (70.7 KB)

DV Fel works?

1 Like

sofar cant,the bl_el test video cant display the “woman”

Wow, it’s clear to support Fel, why? Different dovi.ko?
edit:My mistake, more evidence needed

Some basic understanding I have:

First step would be check if two HEVC video streams are getting decoded.

The AML Decoder from what I see pulls out the EL from the NAL and sends to a 2nd decoder, so should see two - one for the BL and one for the EL if enable debug logging etc.

If that is happening, then need to check the Composer element - but that is in the dovi.ko so maybe not much can be looked at.

1 Like

they are in diffrent dv mode,the first in player-led mode,the second in none player-led mode

DV mode does not affect Fel support

i tested two vedio from coreelec forum,bl_el.mkv and FEL TEST ST DL P7 CMV4.0 4000nits V3.mp4.none of them can steam fel.

1 Like

You’re right, at 19 seconds, can’t be said to support Fel, more evidence is needed

i switch p8.1 to lossless mode,play the test video agaim.whole screen black.may that means no p7 fel supported.

1 Like


CoreELEC (official): 21.1-Omega_nightly_20240623 (Amlogic-ne.aarch64)
      Machine model: Ugoos X4
     CoreELEC dt-id: sc2_s905x4_ugoos_x4

CoreELEC:~ # dmesg | paste
CoreELEC:~ # systemctl status opentee_linuxdriver.service -l --no-pager | paste
CoreELEC:~ # journalctl -l | paste
CoreELEC:~ # ce-debug
CoreELEC:~ # ifconfig | paste

My feedback is that I and my netizens have studied and modified the DTB file together. My goal is to solve the problem of not needing to replace the modified DTB file in the next update without affecting ugoos x4. I have sent out the relevant logs of the DTB file I have modified now. Could you please take a look when you have time? Thank you.

dmesg | paste

CoreELEC:~ # mount -o rw,remount /flash
CoreELEC:~ # fdtput -t s /flash/dtb.img /soc/pcie@f5000000 status okay 
CoreELEC:~ # sync 
CoreELEC:~ # reboot

I got it through the command above, but I don’t have the source code you mentioned.

After two days of testing and cable replacement, it was found that the cause of screen flicker and sound lag was an issue with the HDMI cable.

The feedback on the CoreELEC system bug under 4oro is as follows:Memory playback will not be able to select a track, and it will change the default track.

When playing many Dolby Vision sources, the screen occasionally freezes, especially when subtitles are displayed, and when the video information interface pops up, it freezes.


Automatically playing the next episode will also cause frame drops

fw_printenv | paste

What do you think willl achive with post random logs all over? Nothing …

1 Like

You’re right, it’s really useless. Anyway, I’ll type the command to solve it in the future. Currently, there’s no problem playing DV movies, regular movies, including iso format movies, and remix movies. Everything is normal, except for the lag phenomenon when playing 60 frames of iso format movies.

Hello everyone, the kernel version of my Tencent Aurora 4pro box is too low, and the official kernel is not upgraded to 5.4.210. May I ask if you will DIY create a manual upgrade to 5.4.210 kernel version!

CoreELEC is not Android, ask your vendor for a update!