Testers wanted: GXL, 1GB RAM devices, Amlogic-ng

We have some problems to finish the port of GXL 1GB RAM devices to the Amlogic-ng (4.9 Kernel).
Some devices are booting, some are not. Non of the team members own such device so we can not finish the implementation.

So I have here some modified GXL 1G device trees what need to be tested before the changes can be merged.

If you have a already working GXL 1G device what is booting with Amlogic-ng it would be good to test these new device trees if they are still working!

These device trees are compatible with 9.2.x Amlogic-ng and 19.x-Matrix.

Just place your uSD/USB to a personal computer/card reader and replace the dtb.img on the COREELEC partition by the attached corresponding device tree. Maybe you make a backup of the current dtb.img before to restore the original when the device is not booting after the update.

Please ensure you have minimum Android 7.1 installed on the device.

Do not update the dtb.img on internal install as when the device tree is not working the device is maybe not booting anymore and need to be hard recovered.

Thank you very much for your support!

Edit: the dtbs are included in current 19.2-Matrix_rc1 nightly.

1 Like

Device: MXQ Pro 4K
SoC: S905X
Ethernet: 100Mb
Android 6.0
Image used: CoreELEC-Amlogic-ng.arm-19.1-Matrix-Generic (fresh install on pendrive)

Tried all of gxl_p212 dtb’s and I can see kodi screen for few seconds, then it crash and reboots.
It booted properly 2-3 times and was working fine but after reboot it crash again and again.

I forgot to say you will need minimum Android 7.1 on the device!

For reference sake, upgrading to Android 7.1 is discussed quite thoroughly in the threads below. There are references and links to firmware that people have successfully installed on various S905x devices:

Yep I know, I’ve tested every available rom and none of them works.
This box is weird :stuck_out_tongue:

Out of curiosity, are you able to program other boxes with the version of burning tool and cable that you have?

I’ve tested the new gxl_p212_1g.dtb on my X96 and my Trongle X4 both with 1/8 GB and they boot and work fine with it.

1 Like

@anon29391075 thank you very much for your test!

Were the devices booting before with Amlogic-ng project?
Doesn’t matter if 9.2-x or 19.x.

Maybe you are able to provide a dmesg as well?
Just open a SSH connection and run dmesg | paste and post the URL shown on the console.

Yes they were already working with amlogic-ng, I upgraded them from non -ng CoreELEC 9.2.7 to CoreELEC 19.1-Matrix_rc2 about a month ago. I first flashed Aidan’s Android 7.1.2 TV rom v7.5 to upgrade the bootloaders.

dmesg X96: http://ix.io/3nNl
dmesg Trongle X4: http://ix.io/3nNo

The above are with the new gxl_p212_1g.dtb.


I have also flashed my Nexbox A95X B7N 2/16GB to Aidan’s Android 7.1.2 ATV rom v7.5. It woks fine in this android system but I have a problem to ‘reboot to libreelec’ (Coreelec in microsd card). The reset button in the AV socket also cannot boot into recovery anymore. Terminal Emulator reboot command also do not work anymore.
How to boot into coreelec again?

This is a different thing, only for testing boxes with just 1GB RAM. For your issue, try ATV4 experience rom, built on Android TV9, seems more suitable.

1 Like

Will try. Thanks.

1 Like

Hello, i tested gxl_p212_1g.dtb, gxl_p241_1g.dtb and gxl_p241_v2-1g.dtb on Vmade S905D (p231) (Vmade S905D 1GB hybrid OTT DVB-T2/S2 support) and all working :astonished: :hugs:. With original p231.dtb i have only black screen. Is possible make the same change for gxl_p231_1g_dvb.dtb?

gxl_p231_2g.dtb also never worked for me, I had to add the following to the dts to get it working:

   ion_dev {
           memory-region = <&ion_reserved>;

   reserved-memory {
           ion_reserved: linux,ion-dev {
                   alignment = <0x0 0x400000>;
                   compatible = "shared-dma-pool";
                   size = <0x0 0x7c00000>;

Thank you for the information. I will create a new set of dtbs today.

The add of ion-dev was one of the fixes in p212_1g :wink:

1 Like

@frakkin64 I updated the first post and uploaded all affected dtb what are modified by the current changes. Also the p213_2g should work now.


Bad news, i tested from the first post:
and i have only a black screen (on Vmade S905D).
So I tried again gxl_p212_1g.dtb and it works. It even works with the original gxl_p212_1g.dtb from 19.1-Matrix (Stable). Some difference between gxl_p231_1g.dtb and gxl_p212_1g.dtb that causes.
But with gxl_p212_1g.dtb works surprisingly well, only after first boot ist set a low resolution.

So you are sure it’s a p213? I guess not. The pxxx does nothing about the SoC type, it’s the PCB board.

If you have Android 7 on the device you can try:
fdtget /dev/dtb / amlogic-dt-id
Maybe it’s /dev/stop, not sure about it.

Screen from android:

@9martin can you try if you have a SSH connection with p231? If yes please make a dmesg log dmesg | paste