The s905x4 box does not detect hdmi signals

when I start my denon amp and my s905x4 box electrically
my box starts before my amp, and the s905x4 box does not detect hdmi signals, so I never have any sound, even if I go to the kodi settings
for me to have sound, I have to restart my box

Is there a way to prevent this?

Don’t turn off you box. It will cost you 10 $|€ a year running constantly…

Turn on amp /TV/Monitor first

Then TV Box last so can read EDID

Sure.Except there are multiple billions of such devices, taking a bit of power while doing nothing. I have over 20 at home. Which makes it all a mindless waste.

EDID can be saved to a file, but it doesn’t help. See: coreelec:video_disp_cap [CoreELEC Wiki]

I’m trying to cope with the problem using to automatically reboot Coreelec, when video config is wrong. On my box wrong is, when dmesg show kernel option vout=576cvbs.

disp_cap removed in 5.4 kernel

Thanks for link
Read the wiki

576 cvbs…

That is analog ?
From AV Port?

Strange ???

Thank you for your answers
from what I understand there is no solution?

My guess is that the behavior is cause by original bootloader from the box. CoreElec could cope with it but it doesn’t. Maybe it is not a problem for supported devices.

I have looked at firmware environment. I think there could be some solutions there. First is to add some delay at boot, in hope that AVR will be ready, when CoreElec boots.
We can check what current delay with fw_printenv and change it with fw_setenv:

CoreELEC:~ # fw_printenv bootdelay
CoreELEC:~ # fw_setenv bootdelay 10
CoreELEC:~ # fw_printenv bootdelay
CoreELEC:~ #

I haven’t tested delay. In my opinion, device starting after power brake is wrong, it should go to sleep or to the state it was before break. I have corrected it with following


    if [ "$(fw_printenv reboot_mode)" = "reboot_mode=cold_boot" ] ; then

Now I turn on device with remote, only when I need it and when hopefully AVR and TV are ready.