Think I found the LG CEC issue but cannot resolve

Having CEC trouble (constant disconnects and ceasing to work) for a long time with CE 19 releases and my LG OLED TV, I researched and found a statement by Portisch to have a look at the libcec github.

There were other LG owners having trouble posting over there. Someone had a look into it and discovered that it is related to the fact that libcec is reporting with device type Recorder (type 1) in the default configuration which the LG does not seem to handle well. Changing to device type Playback resolved the issue for this user (type 4 is the suggestion).

libCEC continuously disconnects from LG OLED TV making CEC impossible to use · Issue #567 · Pulse-Eight/libcec · GitHub

So in our case I assume this is changed in

~/.kodi/userdata/peripheral_data/cec_CEC_Adapter.xml

parameter

<setting id="device_type" value="4" />

I can edit the file but do not know how to apply the change. Restarting Kodi (systemctl or reboot) overwrites the file with the old device type 1 setting. I assume this happens because the device type parameter is not accessible from within Kodi and not part of the Input Peripheral configuration.

Please have a look into this issue or advise what I could do on the command line to apply the configuration and make it persistent.

Thanks!

You might need to stop Kodi before editting the file. Configs are cached in ram and is written on exit.
Stop Kodi

systemctl stop kodi

Edit the file
Bring Kodi back

systemctl start kodi

Reference: Cec_cec_adapter.xml is overridden on restart - Help and Support / Vero 4K / Vero 4K + - OSMC Forums

Thanks!

This is sticking and survives a systemctl restart kodi now.

Commencing my long term test whether this takes care of the LG issues.

1 Like

Nice to know, so this should be a user option in Kodi to adjust the device type!? Should be doable, I will see how to implement this. Type 4 is the playback device:

2 Likes

@cruse please test with this image. It will have the new option Represent type of device. You can there select the device type you need, default is the Recording Device. After changing this option a reboot is required. Please report back if the option is working, thx.


Test image including this new option: