TrueHD/Atmos stuttering without passthrough

Running on an Odroid N2 on CoreELEC 9.2.4, although i’ve experienced the same issue on atleast 9.2.3 as well.

I have enabled audio passthrough, but deselected “Dolby TrueHD capabable receiver” as my receiver does not support it. When I try to play a video with a Dolby TrueHD / Dolby Atmos audio track the sound starts to stutter and it becomes unwatchable. As the video is having multiple tracks (like DTS/DD+) I would expect it to select any of those. When I instead enable passthrough for TrueHD I get no sound (as expected). Manually switching to any of the other supported audio tracks the sound works fine.

Is there any setting i’m missing to make it to default to any of the other supported audio codecs?

Log: https://pastebin.com/mhiYE79f

Fixed the stuttering by setting channels to 2.0. However this leads me to not having sorround, if I don’t go in and change the audio track manually each time. Is there any way to make it default to any of the supported audio formats?

You need to select the Multi Channel PCM HDMI audio device, and use 7.1 channels.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice