TrueHD with Dolby Atmos 7.1 sound skipping (11Mbps audio bit rate)

This problem is driving me crazy too.

I wish that I had the programming ability to incorporate the reported fixes into Kodi.

There are more and more atmos soundtracks it Renders a core function of Kodi completely broken.

Yeah, and considering how long this keeps being a issue, I would say it isn’t easily solvable (if at all). This and the DV layer playback status (I get why it probably never will be done, but still) sure are significant blows to everything Kodi at the moment.

I myself was seriously eyeing a S922X box as an upgrade path for my S912… but it seems I’m better off looking for alternatives.

Last night I ran into this problem for the first time when attempting to watch Free Guy.

1 Like

Same here, Free Guy (UHD version with Atmos track) is the first time I experienced these drop-outs.
When comparing it with other movies it has indeed an above average high bitrate Dolby TrueHD / Atmos track.

1 Like

Free guy was the movie that triggered my most recent annoyance too.

Most movies it only happened once or twice and I can live with it. But free guy was unwatchable until I turned off bitstreaming which made kodi send 7.1 pcm instead ( losing the atmos )

It’s ok for me to do that. But my family wouldn’t know what the problem was more the workaround.

I would pay the kodi Devs if they could fix this

1 Like

Both of those issues should be solvable. Other software players are able to do them. The DV one requires compatible hardware so is trickier but as I said other software players do it. The atmos one is already fixed in many software players including ffmpeg so kodi need to get onto it.

1 Like

I agree that they “should” but it will take time (well, it already is taking, isn’t it?). Of course, we can’t really expect it to be any faster because of the nature of the project. Official Kodi HDR support took more than 2 years to be done, and honestly I’m surprised it didn’t take longer.

Those boxes usually are considered obsolete in 3, 4 years max (just see that happened to the non-ng Amlogic SOCs). That means you better buy something that satisfies your needs today, or you risk wasting the better half of the lifetime of this gadget just waiting for some coding hero to come along.

In a utopian world everyone wanting to use Kodi would be a programmer able to help with the project, but we know how it really is…

1 Like

You’re right. Team Kodi have no interest in this issue. They have locked the ticket on GitHub to Devs only which is their right of course. Also stated that no one is working on it. I did politely try and reach out to the dev who has it assigned to them but I haven’t heard anything from them.

For now I’ll have to program a simple button in to my remote system that toggles bitstream Audio on and off. I’m sure I can code that via the Kodi api

X96max plus had same problem when play free guy. No problem with sound track DTS HD-MA. But DTS will lose Atoms channel :weary:

The problem isn’t with the atmos soundtrack itself. The problem is the long known about bug in the way Kodi packs the truehd soundtrack into the bitstream. I don’t have enough coding skills to fix it sadly. That is why DTS HD-MA works fine. Also you can use the atmos track but turn off bitstreaming and send 7.1 PCM audio instead which Kodi decodes. Both ways will get essentially the same audio (ie no discrete overheads). Fortunately I have a Trinnov processor on which the upmixing is very good but I would still prefer proper atmos to work. Hopefully with more and more atmos tracks team kodi can work on fixing this. They definitely know what the case of the bug is but they have said it’s a big job to fix it :frowning:

1 Like

Some good news. Kodi dev has got a working patch. It’s not yet finished but early work is promising and seems to play free guy without dropouts.

Hopefully it will be incorporated into a née release of Kodi soon.


Source for this claim?


Thanks @TheCoolest

Yes. That was the fix that I was referring to.

I am going to try and build a version of Coreelec today with the fix applied. Will let everyone know how I go.


Imma include this in my build and see if it regression tests correctly. As most of my 4kuhd blurays did work fine. They are from 2019-20 tho the newer ones might be problematic.

FreeGuy seems to be the best example, i wonder if theres another prominent one.

Zootopia around the 10 minute mark (9-11).

Think that I’ve managed to build Coreelec based on the 19.2 release but with the truehd fix backported. It took me a while as I’ve never built CE before so I was unfamiliar with GitHub too.

Unfortunately I have had time to test it yet. Will do so in the next 24 hours.

Basically I forked Coreelec and CE version of xbmc and Modified both of them. It should work. It’s been a good day learning experience.


Good news

I have compiled Kodi with the fix for high bitrate atmos successfully and used it in Coreelec.

Works perfectly.

Free Guy
Pirates of the Caribbean 5.

All play without any skips at all.

It’s a bit of a pain to get it working in Coreelec without reinstalling a new image. But i managed to do it. I didn’t want to ruin my old installation.

After building my fixed version I copied the Kodi.bin file to the storage/.kodi/system folder ( called it kodinew.bin). Then copied all the kodi.service startup scripts to storage/.config/system.d and in the kodi.service script changed to location of kodi.bin to my new file.

Starts up now to my fixed kodi. And all the files play perfectly.

By the look of things kodi are planning to backport the changes into matrix so hopefully it makes it into 19.3 and therefore into official Coreelec 19.3 and I can revert back to a standard install.

But importantly this looks like the issue is definitely fixed!!


Even better news:

CoreELEC 19.3-Matrix fixed the skips in Free Guy!
Did not try other titles but I assume they are also playing without skips.

Just upgraded to 19.3 and tried playing Frozen 2 which had many unwatchable scenes before due to the Dolby Atmos skips. Skips are gone now and the movie plays perfectly! I can’t tell you how happy I am about this fix! :grinning:

1 Like