TrustOnX Player (TOX3) S905X4 - ETH not working on NE but working on NG! FIXED - Solution available!

I just swapped out my HK1 Rbox X4 with this TOX3, moving HDMI cable from Rbox to TOX3 and same issue. Rbox is running the same CoreELEC version. That eliminates everything externally. Problem has to be with CE on this device, but don’t know what.
I can do a factory rest of the existing Android, but doubt if that would make any difference… I am at a total loss of causes this issue. Perhaps an HDR setting on this device??

Edit: I tried all three HDR settings under system/CoreELEC, but still no change.

Just installed the NG version on a new microSD card, same thing.

Did a factory reset on the box, same issue… I am out of ideas.

Problem, exist on both NE and NG versions. Next I will try a different device try.

Tried this device tree, same issue >> sc2_s905x4_ugoos_x4.dtb

Try the NE 21.0 Omega nightly on your new microSD.

VC-1 was every time buggy on Amlogic SoC.
So all media this kind are handled progressive and forced deinterlace. This might take to much power when Bitrate is to high. Best is to avoid this codec if possible. I don’t think this issue will be solved in future.

I am running CE on several of my devices, but this is the only device that has that issue. The VC-1 videos play perfectly on those other devices.

When I first installed CE on my HK1 Rbox X4, it had a different issue with that VC-1 codec, and YOU solved it. But it was a different issue, that codec was maxing out the cpu cores and would not play at all… This issue is where the colors are all washed out, pic is only black and white, no color.

I tried that one also. Same issue.

Have you tried the HK1’s power adapter with the TOX3? I once had a box giving weird issues until I swapped its power supply.

That is another good suggestion, will try that later.

Today, I have been swapping ROMs. First, I made sure I found the stock firmware for this box. I burned it onto this box and it was exactly as I received it.
Next, I burned in to this box anther modded ROM, but when I ran CE, same issue… arggggggggg.

Tested a couple more ROMs, then finally settled on Slimbox’s ATV ROM, but still no dice on getting the VC-1 codecs to play under CE. I have no idea what is different in my TOX3 box.

Of course, that codec, VC-1 will not play on any of my devices running Android, except the Nvidia Shield. So, to get it to play, that codec has to be played using my CoreELEC boxes or the Shield. And, I have a LOT of Android boxes, Amlogic, Rockchip, Allwinner, etc.

Anyway, back to the Slimbox ATV ROM, it is fantastic. Using Kodi, his ROM allows all of my HD audio codecs to play, Dolby TrueHD, DTS-HD MA, etc. It also supports automatic frame rate and resolution switching, which is amazing for these “cheap Android boxes”. Of course Kodi will not play the VC-1 video codec. What is confusing, all of the Amlogic boxes says they support that codec, but I have not found one Amlogic box that supported that codec natively.

Now, back to swapping ROMs on this box, is tricky. As a background, I have “swapped” firmware’s probably hundreds of times in the last 10 years.
Each box seems to be different in how to “swap” firmware’s. This specific box, I have to use the power supply, a lot of newer boxes do not need that.
Anyway, I had to open the USB Burning Tool (3.1.8), add the “img” file, and click Start. While depressing the reset button, I connect a male to male USB cable to the PC and box. When I hear the “beep”, I plug in the power plug, then the box gets a new firmware.

If you want to try that ATV ROM, here is the link >> TOX3 — slimBOXtv

Just sapped power supplies, and same issue persist. I guess it is not meant for me to play those VC-1 videos on this box. They play great on my HK1 Rbox X4, and it has the same Amlogic SoC.

Time to start drinking again. Time to buy some stock in Jim Beam.

I still cannot get the VC-1 video codec to play correctly using CE, but in the process of finding a solution, I found something very interesting.

I tried 3 different ROMS for this TOX3 box, but finally found Slimbox’s ROM to exceed my expectations. It supports the HD audio codecs AND supports automatic frame rate and resolution switching.

At the end of the video, you can see what I am talking about CE playing that pesky VC-1 video codec…
Here is my video of this box running Slingbox’s ATV ROM.

Thanks, remote works fine

Thanks for the configuration file!
VFD is working just fine

Thanks again!

You’re most welcome!

1 Like

Issue seems to be fixed on NE Had vc1 issues esp on NE.21 Tried latest NE nighty that came out today (20240404) with VC1 and eth (300mbs on mine.