TVHeadend 4.3 built from source = Segmentation fault

I am trying to build TVHeadend 4.3 for CoreELEC from source (Ubuntu 20.04):

git clone -b coreelec-19
cd CoreELEC
./scripts/create_addon tvheadend43

and the result is:

2022-11-27 18:49:12.847 [   INFO] main: Log started
2022-11-27 18:49:12.852 [   INFO] config: loaded
2022-11-27 18:49:12.853 [   INFO] config: scanfile (re)initialization with path <none>
Segmentation fault

I thought that maybe it depends on something DVB-related from system image, so I removed build dir and started from scratch:

rm -rf build.*
make image
./scripts/create_addon tvheadend43

Unfortunately, result is the same. What am I missing?

I tried it and it runs - addon installed without any user configuration.

Try to run it with gdb to see where it crashes?

Thank you for the hint! Right now it’s built without debug symbols, so it only gives:

[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/".

Program received signal SIGILL, Illegal instruction.
0xf7591288 in ?? () from /usr/lib/

I’ve set up a clean VM and building now from the very scratch, if the segfault persists, I’ll try to build with debug symbols included.

BTW addon from CE repo runs fine.

Now I build one fresh image + fresh addon and it works too.

Maybe the issue is some wrong include or something like that from host because crash happen in libcrypto?

Built on a freshly-setup VM and the segfault is gone… But I’ll keep looking for a reason as if fails on my native host and a WSL setup.

Thank you @vpeter for your support!

1 Like

Hello guys,
With the TVHeadend 42, 8K broadcasts in Türksat are watched, but I get a black screen with TVHeadend 43.
Is there any solution to this?

Have you ever tried docker? I now use it for tvheadend. It has more up to date builds

I haven’t tried docker

I’m trying to build tvheadend43 for the latest CoreELEC 20 version with the latest changes. I need those because they should fix my disappeared tuners lately.

Could I just edit the and update the PKG Version with the latest commits from Commits · tvheadend/tvheadend · GitHub ?

You need to adjust PKG_VERSION and PKG_SHA256, which can also be empty.

Or you can try mine: 26.78 MB file on MEGA

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.