TVheadend choppy

TVheadend is running choppy (10-15fps) after around 10-20 seconds, sound is flawless!
[no difference if SD, HD or 4K]

I am using my config flawlessly for nearly 1,5 years on my S905X3 (and S905X).
S905X3 – 4GB --32GB
CoreElec 9.2.2 stable
TVheadend server: 9.1.121
TVheadend client: 4.4.20.1
(Also tried with AMLOGIC-CODEC options activated and deativated!)

==>System Information in Kodi show all 4 cpus are around 40-60%
before updating yesterday only two ran around 10-20, the other two below 0-10%
(was on 9.2.1 nightly_20200226 fresh install)

Any advice or info, on troubleshooting ??

==> ‘top’ says:
CPU%. MEM%
4359 root 20 0 835632 337880 173812 S 132.1 8.6 9:39.43 kodi.bin
4296 root 20 0 178664 32316 18440 S 21.2 0.8 1:42.50 hyperiond
4050 root 20 0 227744 96756 7480 S 8.9 2.5 0:45.20 tvheadend
1178 root 20 0 0 0 0 S 0.7 0.0 0:04.36 kworker/2+
3708 root 0 -20 0 0 0 S 0.7. 0.0 0:01.88 kworker/u+
7 root 20 0 0 0 0 S 0.3 0.0 0:00.82 rcu_preem+

What information do you get from tvh server? Did you check the status tab? Did you check the log activated on the bottom right corner of tvh webpage? What’s your tuner?

My TVH client on my iPhone runs all programs flawlessly, so I guess it is the client which is causing the problem!
Just deinstalled the TVH-client, and now need to reinstall the addon - but repo is gone :wink:

The log in TVH_server_webGUI is empty / is there any way to activate verbose output ?
Tuner is Fritzbox 6591

==> Now I have the problem, that I cannot reinstall the TVH-Client, because it is not part of any known repo :frowning: ---- Please Help ----

Tvheadend HTSP client is in CoreELEC Add-ons, in PVR clients.

OKay, somehow the search did not find it - manual navigating and installing worked: thx

NOW BACK TO TOPIC:
Log says:

2020-04-14 20:48:54.519 mpegts: 330MHz in DVB-C Network - tuning on SAT>IP DVB-C Tuner #2 (192.168.177.1)

2020-04-14 20:48:54.519 subscription: 005D: “127.0.0.1 [ | Kodi Media Center ]” subscribing on channel “Das Erste HD”, weight: 150, adapter: “SAT>IP DVB-C Tuner #2 (192.168.177.1)”, network: “DVB-C Network”, mux: “330MHz”, provider: “ARD”, service: “Das Erste HD”, profile=“htsp”, hostname=“127.0.0.1”, username=“127.0.0.1”, client=“Kodi Media Center”

2020-04-14 20:48:54.630 http: 127.0.0.1: HTTP/1.1 HEAD /imagecache/707 – 404

2020-04-14 20:49:02.445 http: 127.0.0.1: HTTP/1.1 HEAD /imagecache/707 – 404

2020-04-14 20:49:02.449 http: 127.0.0.1: HTTP/1.1 HEAD /imagecache/903 – 404

2020-04-14 20:49:06.721 subscription: 005D: “127.0.0.1 [ | Kodi Media Center ]” unsubscribing from “Das Erste HD”, hostname=“127.0.0.1”, username=“127.0.0.1”, client=“Kodi Media Center”

2020-04-14 20:49:06.723 subscription: 005E: “127.0.0.1 [ | Kodi Media Center ]” subscribing on channel “kabel eins Doku”, weight: 150, adapter: “SAT>IP DVB-C Tuner #1 (192.168.177.1)”, network: “DVB-C Network”, mux: “282MHz”, provider: “Unitymedia”, service: “kabel eins Doku”, profile=“htsp”, hostname=“127.0.0.1”, username=“127.0.0.1”, client=“Kodi Media Center”

after zapping a little bit and trying diffrent SD + HD channels the CPU percentage of KODI.BIN rises to over 300% (maximum would be 400%, hence 4 CPUs) – never experienced this: seems like an obvious memory leak:

  • maybe to old EPG flaw ?
  • or has it something to do with updating from the nightly? (_I can easily do a fresh install, if it helps

Please confirm that hw decoding is activated and when playing a channel check the display info to confirm it’s hw decoding.

So: finally did a fresh install on the S905X3 with CoreElec 9.2.2 and installed TVHeadend Server+Client addons.
starting channel - channel (after some seconds) is choppy again :frowning:
HW-decoding is activated
how can I verify the hardwaredecoding /display info???

–>It has to be the S905X3-TVH-Client!
Tested it with an suuuper old cheap Android 4.4 Tablet, an iPad2 with IOS9 and iPhone XR with current IOS… all working flawless/luent channels in SD & HD

another occurance: the first minute or so runs smoothly - WHILE it runs smoothly hitting the BACKbutton (to enter menu) makes video in background choppy !!! – Also NO EPG is is shown an neither of the channels!). :: edit: EPG is slowly showing up on SD channles, while all 4 CPUS are running 90-99% !
Stopping the TV-Video all CPUs resume to 2-9%

Your other type of videos play well? The display info is the o key on keyboard. You can use a remote app or a key in your remote if it’s assigned to it.

video decoder: am-mpeg2(HW)

Test #2:
Flashed latet CoreElec 9.1.2nightly to my devices - restored from the same kodi-backup via [system-coreelec-restore] as the clean 9.2.2 install
–> after reboot device updated itself to 9.2.2 final
===> all TV Channel running smooth !!! (cpu0=25-30%, cpu1-3=5-15%)
That is soooo weird :frowning:

So it auto solved? That’s good! :grinning:

Problem just occured AGAIN after 1,5 days (4-7 hours a day) running flawlessly.

Now the info says. SOFTWARE decoding (was hardware) :: so there is the problem.
In SETTINGS - PLAYER - VIDEOS:

  • hardware acceleration allowed is on
  • accelerate MPEG2 - always
  • accelerate MPEG4 - HD and UP
  • accelerate h264 - always

only change I did was adding ‘remote.conf’ and ‘vfd.conf’ to the /.storage/configfiles
Already removed OpenVFD addon and those files – no change: TV is now always SOFTWARE-decoded.

Any hints on how to troubleshoot further?

Did a fresh install with 9.1.2nightly20200415. Absolutely same Config
==> Decoding in HARDWARE is ok! and CPU is now less active (only stable 61° instead of 74°)

So it has to be something with “9.2.2 + THV-Client”.

THX

I use 9.2.2 + tvh client on a daily basis and never had this problem. Something was broken with your setup.

I too use 20200415 and TVH constantly but have not experiences any issues.

I did find that 20200413 caused all manner of corruption to TVH config but 20200415 did not exhibit any issues.

If your fresh install included adding other elements and addons then try again solely with TVH and see if that helps as it might potentially eliminate or point to a conflict with something new being introduced.

@Compent
I am talking about 9.2.2 stable, where THH-clientis not using HW-decoding as well as Kodi itself using much more (/too much) ressources, compared to 9.1.2 on an S905X3

UPDATE 20200509: Did a Clean-Install on my Khadas Vim3L of CoreElec 9.2.2 with recent TVheadend server+client from repo. --> Video is Choppy after 3seconds, until it even freezes CoreElec completely

Decoding is == SOFTWARE, though settings are: USE HW = ALWAYS
(this only refers to the TVHcleint under 9.2.2. latest 9.1.2 nightly works flawlessly, so do my other devices (iphone + android)

Can you advise the source of these streams ??

Is it DVB-T which i use all the time with no issues.

It’s (german) DVB-C (Vodafone / former Unitymedia)

As said: under latest 9.2.1 nightly working fine since CoreElec 9.0.x

About | FAQ | Terms of Service | Privacy Policy | Legal Notice