TVHeadend hstp client can't be loaded on CE 8.95.0

since today there is a problem that tvheadend hstp client can’t be loaded for unknown reason. I have this problem on two different S905 machines. It seams that the addon which is installed form the server repository doesn’t work anymore. How can this problem be fixed? I also tried to reinstall clean CE and got the same problem.


I have a server & client on my S912, & my s905 used as a client.

Check your ipaddress, user name & password.

Did your addons update from My mediaportal one did and wouldnt work either

16:22:44.237 T:3987919728   ERROR: Unable to load /storage/.kodi/addons/pvr.mediaportal.tvserver/, reason: /usr/lib/ version `GLIBC_2.28' not found (required by /storage/.kodi/addons/pvr.mediaportal.tvserver/
16:22:47.853 T:3987919728   ERROR: UpdateAddons: Failed to create add-on MediaPortal PVR Client, status = 5

I still had the previous because this was a new install so i was able to roll back

Since today i’ve booted my tanix mini and i have the same.
tvheadend client cannot loade anymore ce 8.90.5

Same here on all 3 of my boxes.

Tvheadend is running fine on the server.
On 8.90.5 on all boxes.

Was working last night.


Fresh install of CoreElec on S912 device, same error with DVBLink PVR Client.
ERROR: Unable to load /storage/.kodi/addons/pvr.dvblink/, reason: /usr/lib/ version `GLIBC_2.28’ not found (required by /storage/.kodi/addons/pvr.dvblink/

Guess the addons need to be rebuilded

All addons were updated 4 hours ago, properly something went wrong:

You can still access old addons in git history:

Same problem on my Mecool Kiii pro. TVHeadend hstp client can’t be loaded. :confused:

Same problem here. My ki pro can`t load TVHeadend hstp client!
Does anyone know a solution???

  1. Download old plugin from github (from deltaray 2nd github link)
  2. Deinstall TVHeadend hstp client
  3. Deactivate automatic plugin update
  4. Install old plugin from zip (e.g. use USB stick)
1 Like

My TVh htsp client is

I have auto update set, I have just tried to manually update, but the version, is still

It still works.

Then you are some sort of wizard because the version in the CoreElec repo is

I go to addons, all, tvhead htsp, open it, version is, As I said, auto update is set, if I hit the update button, it shows coreelec tvh, I then update, it fails. So I assumed I have the latest version.

I don’t see the screen you show.

Generally, I update anything as soon as a newer version of anything comes along.

Just noticed, I am running coreelec 8.95.0, but the addons are for 8.95.1, where did you get that?

Maybe @anon88919003 bumped all the addons because he is releasing 8.95.1 very soon or he didn’t noticed that they break 8.95.0

My tvhclient 4.3.2 + tvh42 9.0.155 works ok COREELEC 8.90.5
NOTE: Disable auto update in add-ons

1 Like

@dazed is correct and 8.95.1 is incoming shortly and the addon’s where updated in preparation for this, because of the bump to glibc recently some addons will be incompatible with previous versions of CE.

Once you update to the latest release when we release it then everything will be okay again.

1 Like

Many thanks adamg, I had the same problem but used a zip from a previous version to install the addon. Looking forward to 8.95.1.

The add-ons have been rolled back, I’ve been informed that the official Beta1 Leia release has been delayed for a week due to ‘flaw’ that was discovered.