Tvheadend & Oscam

I managed to get Tvheadend and Oscam talking to each other the other day, but after a reinstall am unable to do so. I’m creating an Oscam client called ‘tvheadend’ by selecting CAs then click on Add -> Add Conditional Access Client -> Type -> CAPMT (Linux Network DVBAPI) then leave defaults ( 9000) unchanged, add Client Name -> tvheadend. Click on Enabled and Create.

Oscam has a user tvheadend, and I restart after add the user to Tvheadend, but the user is shown as offline. In the Tvheadend it shows the following every three seconds:-

2019-07-05 21:56:12.712 capmt: tvheadend: Cannot connect to (Connection refused); Do you have OSCam running?

2019-07-05 21:56:12.712 capmt: tvheadend: Automatic reconnection attempt in in 3 seconds

What’s wrong? Wrong listening port or permissions? What else could it be?

In the Tvheadend log I get the following msg every 3 secs?

2019-07-06 14:08:55.932 capmt: abc: Cannot connect to (Connection refused); Do you have OSCam running?

2019-07-06 14:08:55.932 capmt: abc: Automatic reconnection attempt in in 3 seconds

Top shows:-

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND                                                            
 3056 root      20   0  565964 117200  56812 S  14.9  4.1 162:10.43 kodi.bin                                                           
 3248 root      20   0  201740  24120   4740 S   2.3  0.8  27:56.53 tvheadend                                                          
22765 root      20   0    2812   1132    768 R   1.0  0.0   1:46.77 top                                                                
 3508 root      20   0       0      0      0 S   0.7  0.0   5:35.03 kdvb-ad-0-fe-0                                                     
 1928 root      20   0   21872   2384   2068 S   0.3  0.1   0:29.19 systemd-journal                                                    
 7357 root      19  -1   40016   3944   1852 S   0.3  0.1   2:38.20 oscam        

so it clearly is running? Why doesn’t tvheadend see it?

When creating a CA client you need to provide a client name, IP address, port, and mode. I selected CAPMT (Linux Network DVBAPI) as type and used ‘tvheadend’ as name and used defaults for the rest. The client is enabled.
tvheadend is shown as a user in Oscam but the status is offline. Not sure how to put it online… Anyone know?

It is going to be online as soon as the connection is established.
Try the following to see, to which tcp port your oscam server is listening:
netstat -pante | grep oscam

tcp 0 0* LISTEN 7357/oscam

This is only the http webif port, so it seems your cam config is faulty, because oscam isn’t listening on tcp/9000.
We can’t give you more hints here, because it is not legal in some countries.
There are enough sources in the internet, where you can get more help.

I want update oscam in coreelec

You can choose:

CoreeELEC service addon Oscam version: r11518 (not updated in a while)
CoreeELEC service entware Oscam version: r11576 (updated two or three times a year)(*)
CoreeELEC service LinuxServer Docker Oscam version: r11579 (frequently updated)

(*) The best for me (fairly updated, easy to install and less resource consuming than docker-oscam)

Today I have updated all my entware applications, including oscam up to r11579 (latest).


opkg update
opkg upgrade

1 Like

How this works?

You need to install entware first.