Tvheadend server receiving no signal

Hi there,

I got this issue with my Odroid C2 and an August DVB-T210 USB stick, using the latest version of CE with the DVB driver set from the latest kernel:

There’s the problem, that TVH server is hardly receiving a signal any more. As a temporary workaround it sometimes works, to switch the DVB driver set to another (not suitable) one, rebooting, switching back to the correct drivers and rebooting once more. Or it works, if I update TVH server. Or to unplug the DVB stick and plug it in again. But all of those workarounds are not reliable. There’s no solution to reliably use TVH. TVH client is reporting, that TVH server has either no signal or is not responding correctly. Often the whole system freezes after a failed attempt to turn on TV reception.

Here’s the output of dmesg, when booting and trying to turn on TV reception afterwards:
nosignal_dmesg.log (68.5 KB)

TVH-debug-log says:
tvheadend-debug-log.txt (2.3 KB)

I already did a complete fresh reinstallation of TVH server and client, but the problem soon reappeared. The DVB-stick should be ok, as it works without any problem at my PC.

DVB-Signal is ok, too. The reception of the signal has no errors, when using a TV-receiver, or if TVH is working now and then.

Do you have any hints to solve this problem?

Best regards

Check the tvheadend settings. One difference I have seen in your logs is that you don’t use <user> <password>, I guess it doesn’t matter but I’ve always used it.

I deliberately don’t use , because everytime I try to set one of these, I lock myself out of the server. This setup procedure is absolutely not user friendly in regards of access control.

Anyway I tried to set it and locked myself out again. Now I reinstalled TVH server and client, but in the setup procedure of there is no longer an item for the DVB-T2 regions in Germany in the list, except the general item “Germany:all”. But that doesn’t work because network-id and transport stream id are set wrong.

Does anyone know a problem for this new problem? :woozy_face:

Edit: I got the solution, configuring TVH server does the trick with scan tables. But anyway, the freshly installed TVH server still says: “no signal”, so the problem unfortunately is still present. :slightly_frowning_face:

Many years ago I also had frequency scanning problems with old mediacenter applications whose name I no longer remember. For this reason I never use regional or country frequency scanning, but global or “Generic: auto”. However, there may be some mux whose channels are not found, usually from small local TV channels and it is necessary to use custom settings for a specific frequency (for example, Bandwidth: 8MHz, Constellation: QAM / 64, Transmission mode: 8k , Guard interval: 1/4, FEC high: 2/3, Accept zero value for TSID: on, …).

If you have problems, try to find the DVB-T / T2 transmission parameters of the channels in your region or your country (, …).

Try to connect stick directly without USB hub.

Thanks all for your suggestions.

Muxes are recognized and the parameters should be ok for DVB-T2 here in Germany:

If TVH server decides to work (for whatever reason), TV reception works fine and reliable until the next reboot of CE.

Directly plugging the stick to the USB port unfortunately doesn’t help, too.

Maybe I should completely reinstall CE, but I’d like to avoid that time consuming procedure, if possible.

Anyway, a happy new year to you all! :confetti_ball: :sparkler:

Probably not helpful but I have a somewhat similar situation where every few days TVHeadend reports no signal. After reboot it works again for a few days. Instead of rebooting, I noticed that I can also do a modprobe -r dvb_usb_dvbsky and then reload the module and everything works.

The issue doesn’t occur for me if I use the crazycat module drivers. Unfortunately I have 3 tuners and the two others are not recognized by crazycat at all, so I use drivers from latest kernel.

Maybe try the crazycat module drivers if your tuner is recognized to see if it makes any difference.

I tried reloading the module, but (as you were already assuming) unfortunately it doesn’t solve the problem.

Earlier I used crazycat modules, as they were the only ones, who worked with this DVB-T-stick. After a while those no-reception-problems occured. Then I switched to the modules from the latest kernel and they worked reliable. But now the no-signal-problem is present there too. The difference is just, that the whole CE-system freezes more easily when using crazycat-modules instead of the modules from the lates kernel.

Hi there,

I did a complete new fresh install of CE, using the image for Odroid C2, DVB-modules from the latest kernel, TVH server and TVH HSTP client and using the default configuration values of TVH server. Additionally I followed all of your suggestions.

The no-signal-problem is still present. :slightly_frowning_face:

Any ideas?

(Anyway, thanks for your suggestions so far.)

Try DVB-T2 mux with AUTO settings:

If this does not help, more debug logs will be needed.

I did so. Unfortunately it didn’t solve the problem.

Here are all the log files I can gather. (Where is the log file of TVH HSTP client stored by default? Unfortunately I can’t find it.)

20200104_dmesg.txt (70.7 KB)

20200104_tvh_log (5.0 KB)

debug.txt (7.4 KB)

The log file from TVH server is huge, if not filtered. I filtered the values tvhpoll, access, dvb, subscription and htsp.

TVH server log from web interface (20200104_tvh_log) already signals “poll timeout” when the server has just started and is not receiving any tv signal. I inserted a bigger space in the log file between this and the section, when TV reception is on.

BTW: There is no HDTV stream profile in the stream list, as cubimol is showing in the screenshot. Can the problem be related to this?

It looks like hardware or kernel driver issue.

Your DVB-T2 stick is identified as MyGica T230, so they should be used modules:

# lsmod | grep -E '^(si|dvb)'
si2157                  7643  1
si2168                 11060  1
dvb_usb_cxusb          97798  1
dvb_usb                23654  1 dvb_usb_cxusb
dvb_core              125671  1 dvb_usb

If so, then:

  1. Enable TVheadend debugging (Debug to syslog, Debug subsystems: linuxdvb, Apply Configuration)
  2. Connect to box via SSH and run this commands to enable kernel modules debugging info:
    echo 'module si2157 =p' >/sys/kernel/debug/dynamic_debug/control
    echo 'module si2168 =p' >/sys/kernel/debug/dynamic_debug/control
  1. Run command to saving syslog to a file:
    journalctl -xef -o short-precise >syslog-debug.log
  1. Turn TV reception
  2. Interrupt running journalctl by pressing Ctrl-C.
  3. Post the file “syslog-debug.log” here.

It would be nice to record also successful tuning for comparison.

Hi Koumes,

thank you very much for your quick response.

lsmod gives the exact same result of loaded modules as you showed in your reply.

Here’s the syslog, when there is the “no signal”-problem:
syslog-debug_nosignal.log (121.5 KB)

Luckily I managed to get TV-reception working by unplugging the USB-Stick once and replugging it. But here on this fresh installed CE the stream is stuttering often. This behavior didn’t happen before, the stream was fluently, once it worked. Here’s the syslog:
syslog-debug_stuttering.log (176.1 KB)

Edit: I’m not sure, if some information is missing in the log file. First I tried the journalctl-command unfortunately I had not plugged the antenna cable into the TV-stick. Therefor I repeated the command with then plugged in antenna cable. The syslog of this “antenna-unplugged” try is:
syslog_antenna_unplugged.log (259.7 KB)

Sometimes is tuned with low SNR between 19.5 and 24 dB and variable error rate (ber=29*10^-7). The signal strength may be too weak for this device.

Alternatively, I can share (here) a custom modded CoreELEC 9.2.1 showing the signal strength in TVheadend.

Thank you very much for your detailed analysis.

I already use an active antenna, but so I’ve got to search for ways of further improving the signal.

At least I now know the source of the problem. Thanks a lot. :slightly_smiling_face:

Hi there,

I repeated the analysis steps once more and I still am unsure, if the problem is just related to a bad signal. (Using the tuner of my TV with the same signal source has perfect signal quality.)

Here are the recent debug logs:
debug_new.txt (12.0 KB)
syslog-debug.log (167.8 KB)

The stuttering in the successful tuning log might be caused through the debug logging itself. Without logging fluent streaming occurs.

Any ideas?

This is not straightforward, I’m afraid. I can tell you that with the same signal source I have different results with Khadas vtv (internal tuner), Xbox usb tuner, mygica t230 tuner and hdhomerun expand. I use dvb-c and there are differences between all of those connected to the same signal source. The Xbox doesn’t tune one of the muxes (273,5mhz I think), mygica and vtv are better but sometimes fail in some muxes (different ones) and the hdhomerun is the best one. So using different tuner can produce different results with the same signal source.

Ah, ok, thanks for your explanation. I just wonder, why sometimes the TV-reception with CE, TVH and the used hardware works fine (after using some tricks), but often there is this “no-signal”-problem. And why this problem has increased. Anyway, thanks all for your efforts.

In any case, getting “no signal” in all muxes seems to be extreme.