TVheadend some channels are pixelated (905 amlogic)

Nowadays some channels with 905 Amlogic are pixelated. I have a Mecool m8s DVB-S Box (same behavior with Alexelec on that box) and a x96mini with the newest Coreelec image.

The Provider is Vodafone Germany DVB-C. (formaly Unitymedia)

Both are showing the same pixel-salad, but only on several (important) HD channels. I tested TVH 4.2 and 4.3.

For instance Sky Sport News HD (freetoair) and the Sky Sport Bundesliga channels (encrypted, tested with local card).

The strange thing is, it worked fine three weeks ago.

Raspberry Pi 3b+ with the newest Libreelec works fine. So it is not a problem with the cable, signal or the provider.

I testet the Astrometa and the Hauppauge WinTV Solo DVB-C Stick. Same results.

I think my cable Provider has changed a little thing and the 905 Boxes are not able to deal with it.

A german user has the same problem.

Here is a log from a fresh installed coreelec 9.2.2 on the Mecool Box.

http://ix.io/2noa

And a record (Sky Sport News HD)

A sample of an actual ts stream would probably be more useful.

Same problem here.
Here you can find a ts-stream sample of Sky Sport News HD: https://gofile.io/d/JQQB0E

That sample plays fine on my Le Potato (s905x) with kernel 4.9 ng build.

Maybe the problen doesn’t occur on the ng-builds.
I only have a Odroid C2. Therefore i’m unable to test with the ng-builds.
The problemm occurs on 2 different Odroic C2.
Current build: CoreELEC-Amlogic.arm-9.2-nightly_20200530.tar

The picture is clear and perfect by disableling hw-acceleration, but in slow-motion (as expected)

1 Like

I can confirm this. With disabled hardware acceleration the picture is clear.

I’ve just tested with a clean installation on an Odroid C2 2G gxbb_p200_2g_odroid_c2 > CoreELEC 9.2.2.
The problem is still there.
Also with the latest nightly […20200531.tar] the problem occurs again.

This has nothing to do with tvheadend.
The Problem also occurs even when i play the ts stram from above from the local sd-card (https://gofile.io/d/JQQB0E).

I’ve created debug logfiles: http://ix.io/2o5O

The problem also occurs on a 905W with the latest stable build of CoreELEC.

1 Like

And also on Astra 19,2 e.

Coreelec 9.2.3. S905W

Debug log ( channel “Sky Sports News HD”.)

http://ix.io/2oZl

The pixel chaos is also there, not as heavy as on the “Sky Sports News HD” cable channel, but after two or threee minutes the box freezes (with a short audio loop).

I tried also the latest nightly a few days ago, same result.
With the nightly no URL from the debug-log will be generated ( I tried many times).

It worked so lovely and well a few weeks ago.

Is there hope?

Or can we throw theese boxes into the garb…?

I think this is an old problem that has always existed in amlogic hardware decoding (first generation S905/S912) and that it has no solution. Crashes seem to happen only on HD TV H264 and not always (see https://discourse.coreelec.org/t/extreme-lag-on-some-h264-videos-s912).

The tvheadend server is not to blame.

There are three alternatives: stop using HD TV channels that do not look good, or replace the hardware with the new amlogic-ng processors, or install the firmware with kernel 4.9 (FunHouse builds) on the old processors.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice