TVLand, other default add-ons fail to play

Hi, I’m relatively new to coreelec and kodi, but not to Linux. I’ve just installed coreelec generic -ng build 9.2.1 on my Beelink g12b-S922x GT-King and the video addons from kodi like HGTV and TVLand fail to play with just “check the log for more information”.

The kodi.log file contains python errors similar to this:

Blockquote> 2020-03-07 19:33:59.272 T:3535795072 ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the followin
g error<–
Error Type: <type ‘exceptions.AttributeError’>
Error Contents: ‘NoneType’ object has no attribute ‘group’
Traceback (most recent call last):
File “/storage/.kodi/addons/”, line 23, in
from resources.lib import tvland
File “/storage/.kodi/addons/”, line 285, in
elif mode == 1: TVLand().browse(name, url)
File “/storage/.kodi/addons/”, line 89, in bro
except: items = json.loads(‘var triforceManifestURL = “(.+?)”;’,response).gro
AttributeError: ‘NoneType’ object has no attribute ‘group’
–>End of Python script error report<–

I’ve pasted all of the kodi.log here

There’s a reference to a DNS problem, but I can ping from the host on the command-line.
“ERROR: CCurlFile::FillBuffer - Failed: Couldn’t resolve host name(6)”

Any ideas greatly appreciated

Under Network in CoreELEC settings enable Wait for network.

Thanks for your help. I’ve enabled “wait for network” but it doesn’t appear to have made a difference.

Seems there is something wrong with this addon. I tried installing it and doesn’t work either.
Try to reporting this to author of this addon.

There’s actually quite a few that don’t seem to work.

  • ABC Family
  • TV Land
  • PBS Kids (doesn’t even load)
  • TYT Network

This is also the stable 9.2.1 release - and all these add-ons don’t work? Weren’t tested? Is that normal?

Only a few others that I’ve tried have actually worked, so it’s not all of them.

You are joking right? You can’t expect that every possible addon would be tested by CE team.

I assume something has been changed in last few months on appropriate servers and addon needs to be updated. And as you can see this addon is very old:

1 Like

I figured it would be more commonly used and thus would be maintained.

Being a first-time user, I think I just wanted to be sure it wasn’t a problem with my setup or configuration that would cause problems going forward.

I picked about eight addons to install - at least five didn’t work. I realize there are dozens (hundreds?) but these were the most recognizable and one of the main reasons I would use this - I was surprised they didn’t work.

Report it to authors of the not working addons.
That´s it

1 Like