TX9 Pro wired network not working (hw change)

I have two TX9 PRO. In the “old”, Coreelec works perfectly.
The last time I bought it, the wired network is down.
I photographed the two motherboards, the new one on the right.

I’ve tried several dtb.img files, but none of them work the wired network.
Anyone have any ideas? Thank you for replying

It could be a problem with cables or connectors, to check this:

  • turn off both devices
  • disconnect all cables in the device that works
  • remove the flash card from the device that works
  • insert the flash card into the device that does not work
  • connect all cables to the device that does not work

if both devices use the same dtb.img it should work

I’m already through many, many attempts.I can not solve it…

If you think ethernet is broken then use only WiFi.

The wired LAN works with Android. With Coreelec wired LAN does not work.
I’m sure dtb.img is responsible for it.

How about telling us what dtb.img you’re using or what you’ve tried or what worked with the old one that works.?
Disclose your SOC too.
I can’t be bothred looking it up.
TX whatever means nothing to me.
Please disclose your harware specs.
I cant see what’s under that heat sink.

Ok. Solved. With gxm_q201_3g.dtb work.
I don’t understand why this is good, but working…