TX95 box boot coreelec


#1

First I want to thank everybody for the work they have done to create the files and for any help anybody may give.

I have a tanix tx95, I confirmed it had 2gb ram and s905x using an andriod app.
Using the LibreELEC.USB-SD.Creator.Linux-64bit.bin,

  1. I prepared both a sd card and usb drive with coreelec-s905.arm.8.95.6-s905.img.gz.
  2. I renamed p212-2gb to dtb.img and moved to the main directory
  3. I tried both a usb drive and sd card while pushing the reset button and plugged in the box and it just freezes at the s905x logo.

Any help is appreciated.

I read from LE that somebody did the following with tanix tx5:

Operating System : Android 6.0.1 Marshmallow (last firmware Oct.2016)
CPU : Amlogic S905X Cortex A53
Processor : 1.5GH z
GPU : Penta-Core ARM Mali-450
RAM : 2GB DDR3
ROM : 16GB EMMC

Now For install LE in Tanix Tx5 Pro :

Actually you have 3 method for install LE but just 1 work with Tanix Tx5 Pro ( again thank you to Kostaman for explain ) :

1. Toothpick method: disconnect the power supply, insert card/drive, use a toothpick to push reset button and connect the power while holding the button. Wait until LibreELEC logo appears and release the button. Used With and Without Device tree. --> Failed (with just the boot animation and no further).

2. Recovery method: boot into Android, insert card/thumb drive and choose Reboot to recovery.(Had to use an APP)
Your box should boot into LibreELEC. --> Failed

3. Recovery method (take 2nd variant): if you have “Update” app pre-installed open it, insert SD card with LE/connect USB drive, and choose any ZIP file in the app for update. Your box should reboot to LE. --> Worked

Just imput a Fake.zip in your SD Card with LE, go to update app on android, Select Fake.zip and press Update.
The box restart and install LE on SD Card

Was anybody able to get a tanix box working using coreelec, if so how did they get it to boot Coreelec?
I was thinking about trying to use a fake.zip but I don’t have access to even copy a new file to the Coreelec sd card and I didn’t see an update app on the android screen.

Thanks again.


#2

Nevermind, I found a workaround. I found an andriod app called reboot to libreelec which boots to Coreelec when I select it.