Ubuntu, KODI chroot ALSA DD+ problem

Dear all,

First of all I would like to thank @Portisch, who helped me with the integration of hyperion in my Ubuntu kernel (GitHub - beta68/linux: Odroid N2(+) kernel with CoreElec media modules/drivers and amvideocap). Using this kernel I managed to run CE KODI in a chroot environment using Ubuntu (N2+ Ubuntu + Kodi + VDR + hyperion.ng - Page 2 - ODROID). I have one remaining small problem with audio where I kindly ask CE team to point me into the right direction.

HDMI PCM is working (stereo as well as DD 5.1) for all videos. However, when playing e.g. an Amazon VOD file, DD+ audio format is not working.

What I tried so far:

  • In my kernel I replaced Ubuntu media and media_modules branch with the CE ones. I compared audio related stuff and DD+ seems to be included in the remaning Ubuntu kernel directories (e.g. audio/soc/amlogic).
  • I copied AML-AUGESOUND.conf to /usr/share/alsa without any effect
  • My /etc/asound.conf looks like
pcm.!default{
type hw
card 0
device 1
}
ctl.!default{
type hw
card 0
}

I am missing the ALSA AML-AUGESOUND Multi Ch PCM device and do not know how to implement this. Do I need to use patched alsa library, is it still kernel related, do I need a different asound.conf file? Any finger point into the right direction is highly appreciated.

Thank you once again for allt he help provided so far and thank you for this awesome KODI distribution called CE.

beta

I solved it. Thank you.

1 Like

About | FAQ | Terms of Service | Privacy Policy | Legal Notice