UGOOS AM6 Plus fails to initialize CEC

Let’s say it doesn’t seem to be caused by CE. I am experiencing the same behaviour when booting into Android.
My solution was to create a config for my receiver’s remote (which supports different devices anyhow). Pro: Keys that weren’t avaliable via CEC can be mapped.
Con: The IR receiver in the AM6 doesn’t seem to work as smooth as the one in my AV receiver. Maybe just some calibration thing. I should probably look into configuring the driver properly. There is some lags and bouncing keys, etc.

Out of curiosity, what is the situation when both boxes are connected? Does CEC work for the AM6 in that case?

Thank you for your answer. I wonder why I got the impression that this device was recommended. I found several comments in their blog about CEC problems after searching for UGOOS CEC issue. Too bad I did not try that before buying one. This should be a huge warning for people who wants something faster. Good hardware is nothing with bad firmware. I haven’t try yet to connect the TANIX at the same time. I will but even if that changed the result, I do not intend to run the TANIX to fix a problem in the UGOOS. I activated logging for CEC but this has no meaning to me except that it contains a lot of errors.

2021-04-25 14:41:37.612 T:4985 DEBUG : CecLogMessage - << Recorder 1 (1) → TV (0): POLL
2021-04-25 14:41:37.612 T:4985 DEBUG : CecLogMessage - << 10
2021-04-25 14:41:37.616 T:4985 WARNING : CecLogMessage - Write: write failed
2021-04-25 14:41:37.616 T:4985 DEBUG : CecLogMessage - << 10
2021-04-25 14:41:37.632 T:4985 WARNING : CecLogMessage - Write: write failed
2021-04-25 14:41:37.632 T:4985 DEBUG : CecLogMessage - >> POLL not sent
2021-04-25 14:41:37.632 T:4985 DEBUG : CecLogMessage - TV not present, not sending ‘image view on’
2021-04-25 14:41:37.632 T:4985 DEBUG : CecLogMessage - << Recorder 1 (1) → broadcast (F): active source (2300)
2021-04-25 14:41:37.632 T:4985 DEBUG : CecLogMessage - << 1f:82:23:00
2021-04-25 14:41:37.650 T:4985 WARNING : CecLogMessage - Write: write failed
2021-04-25 14:41:37.650 T:4985 DEBUG : CecLogMessage - << 1f:82:23:00
2021-04-25 14:41:37.666 T:4985 WARNING : CecLogMessage - Write: write failed
2021-04-25 14:41:37.666 T:4985 DEBUG : CecLogMessage - failed to make ‘Recorder 1’ the active source. will retry later
2021-04-25 14:41:37.666 T:4985 DEBUG : CecLogMessage - << Recorder 1 (1) → TV (0): POLL
2021-04-25 14:41:37.666 T:4985 DEBUG : CecLogMessage - << 10
2021-04-25 14:41:37.687 T:4985 WARNING : CecLogMessage - Write: write failed
2021-04-25 14:41:37.687 T:4985 DEBUG : CecLogMessage - << 10
2021-04-25 14:41:37.702 T:4985 WARNING : CecLogMessage - Write: write failed
2021-04-25 14:41:37.703 T:4985 DEBUG : CecLogMessage - >> POLL not sent
2021-04-25 14:41:38.666 T:4985 DEBUG : CecLogMessage - << Recorder 1 (1) → TV (0): POLL
2021-04-25 14:41:38.666 T:4985 DEBUG : CecLogMessage - << 10
2021-04-25 14:41:38.670 T:4985 WARNING : CecLogMessage - Write: write failed

I wrote to them yesterday in the official UGOOS store on AE but I think it will have no effect. The “best” I can do now is to publish a bad review which will have no effect either.

This log shows a hardware issue “outside” of the CE device. It can be a broken cable, no CEC support by TV or no CEC enabled on the TV at all. Or if an AVR is used as it mostly break CEC communication.
CEC is a single wire bus, so there can be a lot of issues. Also it’s possible that the TV does have a wrong CEC implementation and does not pull up or does not release a pull down.

The only option left from CE side is to inject BL301 and enable the USB power option. Maybe the Ugoos hardware does need this option enabled to power the CEC connection. If this does not help you need to test with another piece of hardware if the TV CEC does work at all.

Thank you for your answer.

The fact is that I have 3 other devices under CoreELEC (TANIX TX92, Minix Neo U1 and Magicsee N5. I use only one at a time) using the same amplifier, same screen and same cables and CEC works perfectly as intended.

I will try that BL301 after I found it. What do you mean by USB power option ?

Thank you. I see that option now. Before trying this, as it seems risky, I’d like to make a call:

Are there other AM6 Plus owners here who could confirm that CEC does (or not ) work ?
I worry that this could be a hardware defect on mine.

I couldn’t wait so I tried and it failed.

Starting bootloader blob BL301 injection tool...

This tool can be used to update the bootloader
blob BL301 of the vendor bootloader on the internal
eMMC. This bootloader blob BL301 is customized by
Team CoreELEC to support all wake-up features like
CEC, Wake-On-LAN, IR, and GPIO wake-up from
suspend or power off state!

Device serial number: 290b4000010d0c00000731384exxxxxx
Using CPU type G12B (29): S922X, A311D
Using binary type because of CoreELEC DT-ID: Generic
Using /dev/bootloader as bootloader partition
Did not find Amlogic image header magic! Error - exit!

You are screwed anyway, the bootloader is encrypted.

0.3.6 is last non-encrypted firmware on that bl301 injection work
But if you have already encrypted firmware then no way back
Ask Ugoos for possible solutions

Of course not. This was only intented for locating the potential source of the problem. In my case it confirmed that the AM6 CEC works reliably (disclaimer: in my environment) once the bus has been initialized, which the AM6 somehow fails to do properly. Since I know nothing about CEC protocol, I couldn’t even tell who’s at fault. It could very well be the case that the AM6 is correct per spec, and my other box just does a little extra to cover up known implementation flaws. Who knows.
UGOOS have not responded to my email about that a few weeks ago.

Yeah, I feel bad but I’m glad you helped me quickly.

I even tried their 0.4.0 beta firmware but it makes no difference.
I now have a very expensive paperweight. It’s good looking though.
It seems that UGOOS AM6 Plus should be renamed to AM6 Minus CEC.

I tried having the TANIX and the ugoos connected at the same time : CEC working for the TANIX and not working for the ugoos.
I even connected to ugoos directly (with their short cable) to the PANASONIC TX-65EZ950E (with all Vierra Link options activated) and it did not work. I must have a bad TV screen and a bad AVR that only works with other chinese brand android players, even the cheapest one (Magicsee N5).

I’ve got the following reply from the ugoos Official Store on AE :

The factory replied:

have no ideas, all CEC working with devices which support it. we have no ready answer. to fix it we need Denon amplifier and Panasonic TV, then can debug

in blind mode is impossible to do

our Yamaha aplifier with Philips TV, also as Sony TV all working best, all possible features

How professionnal !
I asked if I have to send them my TV and amplifier or buy new Yamaha and Philips.

I remembered that I have a recent SONY TV and I tested the ugoos connected to it and CEC works.

So, for anyone interested by this great hardware, you know now that ugoos CEC does not work at all with DENON and PANASONIC (the list is probably longer than that).

I can confirm that CEC works with an Yamaha RX-V4A, Samsung Q80T.

1 Like

The part about Ugoos FW and not being able to inject bl301 on any version after 0.3.6 due to it being encrypted is true.
However, I have Ugoos AM6 plus, and can confirm that no matter which FW version from Ugoos after 0.3.6, CEC worked with CE19 beta2 reliably with my Panasonic Plasma TV while it was in beta, before stable and official 19.0 release. I have older 19.nightly from january 13th and CEC works flawlessly. Regardless of any Ugoos FW version after 0.3.6. I’ve tried all Ugoos latest FW versions and now I’m on latest RC 0.4.1. Results are always the same - for CE19 if on old nightly 19.0-Matrix_nightly_20210113, CEC works for every command. If I install any later version of CE19 from first stable version 19.0 and up to 19.1 CEC seems to work at first, but if I switch HDMI sources and turn off tv then it will stop working until I reboot CE19. I have 19.0-Matrix_nightly_20210113 archived update file, and that is why I’m using that one, maybe some other older beta nightly from that period would also work.

So I reinstalled CE19 19.0-Matrix_nightly_20210113 and I’ll be using it until someone can point me in the right direction. I’m willing to try and edit Ce19 config on my box myself if anyone has any idea how it can be adjusted for combination with Ugoos AM6.
I know I should have switched nightlies regularly and should have reported it sooner. But during the last 6 months I had some health issues and sadly I have been preoccupied with visiting medical doctors for many exams and medical procedures. That’s why I turned of updates off during this period, so my wife would have no hassle and no problems with the Ugoos box. I did update once or twice from that nightly to 19.0-Matrix_nightly_20210116 or 17 I can’t remember, and CEC also worked fine when switching sources or turning off tv, but I don’t have that version archived or saved. So it got lost the first time I updated to CE19 stable.

Now that I have tried to update It seems to me that something has changed regarding CEC in CE19 somewhere in between beta2 and first stable release. I suppose it works better for most boxes and people but not Ugoos AM6. I also read that Panasonic is notorious for its CEC implementation and that also may have something to do with it.

Anyway to summarize, for me CEC works when Coreelec is first booted but loses connection if I switch HDMI sources or turn of / standby TV, for any CE19 version from 19.0 stable (including later RC versions rc1 and rc2) up to 19.1stable or latest nightlies.
When I revert to 19.0-Matrix_nightly_20210113 CEC works flawlessly and most reliably regardless of switching sources or turning tv off.
I’d appreciate it if anybody can suggest some adjustments in files or configuration on Ugoos AM6 box.

Log file:

1 Like

I haven’t been able to find it in archive, could you share it ?

Sure. Sorry for late answer, I must have missed notification, been busy a lot. I only have upgrade file, don’t have new install image.
I have it installed into internal memory. The way I do it with Ugoos AM6 on encrypted firmware is first installing official Ugoos dual boot firmware, reboot into CE. Ugoos put CE 9.2.2 version. Then I update it from this file by simply putting it into .update folder. It works for updating from CE 9.2.2, and also from CE9.2.7 if it automatically updates to latest CE 9. Of course, the same as CE devs, I also don’t recommend installing to internal memory unless you’re absolutely certain of what you’re doing and aware of the risks associated. Injecting bl301 will not work on Ugoos encrypted versions of firmware (from 0.3.7 upwards if I remember correctly).
For recommended way of installing to micro SD card, I would first install latest single boot Ugoos Android firmware (because if you install dual boot it will default to booting coreelec from internal memory every time and would only boot from SD card if you press recovery button), and put latest CE 9.2.7 new install coreelec img to SD card. Then i would boot to SD card by using recovery button. and then would upgrade to provided CE19 beta nightly. Make sure you reject and turn off updates otherwise it would autoupdate to latest CE19.2 stable/nightly.
Please let me know if you need any assistance.
Also if you do it via SD card, don’t forget to download remote config files for Ugoos AM6 Plus remote from repository. Put it into root of prepared SD card or later place it into .config folder of CE and reboot.
I may as well attach it here too:
If you use dualboot from Ugoos the file is already present and you don’t need to do anything in order to use ugoos remote controller.

Thank you for the files and explanation. A few weeks ago, when they released v0.4.1, I tried flashing the official dual boot firmware and almost lost control of the device for good. So I’ll test this soon on a SD card.

I confirm that CEC works with this version (Amplifier volume control and TV + Amplifier power off with DENON AVR-X2400H and PANASONIC TX-65EZ950E).

Is there a chance that CE devs would look into this now that we have a (second) proof that it works with CoreELEC-Amlogic-ng.arm-19.0-Matrix_nightly_20210113 and not with the most recent version ?

1 Like

About | FAQ | Terms of Service | Privacy Policy | Legal Notice