Ugoos AM6B+ ethernet issues

So couple of days ago I set up my second Ugoos AM6B+. First one was a breeze, decided to order a second. I am setting it up in the same install location as the first, using the same network cable (back to my main switch which is wired to my router).

Having installed CE I am finding (whether from USB or eMMC boot) that quite regularly, Kodi will not find the network, but the device can be connected to over SSH. If I switch to a USB3 ethernet adapter, everything is fine. Switch back to the device ethernet port, and I intermittently get issues. I’ve tried K21 stable, the latest nightly and the problem persists.

I’ve set up many Kodi devices and have never experienced this before. If I reconnect my first Ugoos to the same network cable everything is fine. Do I perhaps have a bad ethernet port on the second Ugoos?

Here’s a shot of the network status according to Kodi after a bad boot, welcome any suggestions.

I also have the same problem… Bought a new one from ebay seller and it only works with ethernet usb adapter… Hardware problem… The seller as always run away and said to use only android OS , but the problem persists in Android, is hardware problem… I contact Ugoos and their support is a crap too, always shooting to user lack of knowledge or coreelec is not total compatible with the box, really bad excuses… bought a minix , all problems gone, Ugoos is done nd buried.

Checking for more info in SSH console with console tools would be useful. Like dmesg, ifconfig, … Maybe some small hw difference.
Also 2 posts and no logs :frowning:

https://wiki.coreelec.org/coreelec:ce_support

thanks for sharing your experience, sorry to hear you’ve had the same issue. I suspect there will be some hassle in attempting to get it replaced, so may have to stick with the USB ethernet adapter.

Is there an easy way to restore the eMMC to factory format in event I can get it replaced?

given the issue being discussed involves Kodi stalling without a network connection, is there a command line for submitting a log instead of via the GUI?

EDIT: this is what I get with dmesg:


CoreELEC (official): 21.1-Omega_nightly_20240522 (Amlogic-ng.arm)
      Machine model: UGOOS AM6B
     CoreELEC dt-id: g12b_s922x_ugoos_am6b
      Amlogic dt-id: g12b_AM6b_b4g

CoreELEC2:~ # dmesg | paste

<html><head>
<meta http-equiv="content-type" content="text/html;charset=utf-8">
<title>404 Page not found</title>
</head>
<body text=#000000 bgcolor=#ffffff>
<h1>Error: Page not found</h1>
<h2>The requested URL was not found on this server.</h2>
<h2></h2>
</body></html>

You need Internet

indeed!!! But after a couple of attempts I achieved a good boot, but still no url. My first Ugoos was fine, the second is hopeless with the built-in ethernet port, but fine with the USB ethernet. I’ve rebooted my router, checked for conflicts, looks like my second Ugoos is a lemon.

paste is currently broken on ce server

Can you set a Manual Network connection and then bind the Mac address to that IP in the router - then set the second box up exactly the same (obviously with a different ip address)?

thanks, we’re thinking along the same lines, I tried a static IP address approach this morning with an address outside my router’s DHCP range and I still had flaky starts where Kodi was struggling to connect to the network. I set a manual address in the CoreELEC add-on, and I also tried it in the Ugoos Android boot (which always reports ethernet as connected).

I’m not sure what’s involved in binding the MAC address in the router, my router always sees the problem Ugoos box (and I can always SSH in), I can take another look in case there is something else I can tinker with in how the router handshakes with the box.

g12b_s922x_ugoos_am6b.dtb (73.8 KB)
Please have a try with this DTB if ethernet start to work, thx.

thanks, I tried that just by replacing the dtb.img on the USB stick I’ve been booting from (root directory), and had the same issue. Do I need to reflash the stick and start afresh?

with the new DTB my dodgy Ugoos has actually got worse. My Kodi database is on my NAS, and previously when booting with the device ethernet connected, while rarely I would get a good boot, usually the CoreELEC splash screen would hang for a while and then give up, switching to Kodi with an empty library, and the Kodi system status showing the IP address as “busy”. With the new DTB, I’m not getting past the CE splash screen, the animation stops and then just hangs.

The new DTB works fine on my dodgy Ugoos when using the USB ethernet, and it also works fine on my first Ugoos via its internal ethernet port.