Ugoos AM6b+ Incompatibility with HDFury VROOM?

Recently got myself an AM6b+ and installed CoreElec (on a CE-21 nightly that is a few days old now) on it as I’m unsatisfied with progress made in Zidoo’s firmware over the last year.

Things seem good so far but I’ve got a weird issue. When connected through my VROOM (I’ve tried a bunch of different EDIDs and settings) everything only works reliably for a single boot.

Specifically there are bunch of resolution/fps combinations that only work during that first boot of the player. I can solve by unplugging and re-plugging in power to the VROOM.

Some detailed steps

  1. Unplug power to everything
  2. Plug back in so everything turns on
  3. Set player resolution to (1080p/60fps, this is a combination that always works for me)
  4. Play a 4K movie so it swaps to 4K/23.976
  5. Exit movie after seeing that is playing correctly
  6. Reboot Ugoos
  7. Try playing movie again and there is no signal on TV and VROOM did not see FPS/Resolution change.
  8. Exit playback by pushing back and player swaps back to original resolution/fps and is displaying again
  9. Unplug and replug in VROOM and play movie again and its correct

Notes:

  • Is unrelated to HDR Format. Some other resolution/fps combinations are unreliable as well (1080i@50fps for example)
  • It is always the same resolution/fps combinations that have issues
  • Is specific to the VROOM, not HDFury. Pulled an old HDFury Arcana from closet and it doesn’t have issue.
  • Already tried HDFury Support and they were stumped
  • Can manually change Resolution/FPS and it has same issue, just have playing movie for example steps to trigger

Setup
Ugoos → VROOM
VROOM → Samsung soundbar with wireless rear speakers
VROOM → Samsung S95B

or

Ugoos → VROOM → Soundbar → TV

Both ways have this issue

Totally possible/probable this is an HDFury issue but figured I’d ask here before giving up. Do not have this issue with my Zidoo Z9X or Z9X Pro

Hi,

Exact same issue with me, HDR content will not work and keep getting no signal