Unable to change HDDs permissions

Hi
I have 3 usb hdds connected to my odroid C4. They all have root/root permissions and because of that I can’t install any docker containers as I get “permission denied” error. I tried to change the permissions with “chmod 755 /var/media/my_hdd” but to no avail. Is there any way to do it?

CE runs as root. Are they ntfs?

Only one of them is, two others are ext4.

Were they used on any PC? You can find in the forum at least one case of drives that aren’t properly disconnected in a shutdown of the PC (there’s shutdown and shutdown holding the shift, I think, to really shutdown the PC). I also had a problem with a friend and a HC4 exactly like that.
You can also try to use PUID and PGID as 0. It’s not recommended because it will give too many privileges to the docker instance but usually bypasses permissions problems.

Yes, they were connected to a PC at some point in the past. The problem with PUID and PGID as 0 is that most containers complain about it and many of them force stop because of that :confused:

This is the problem I was referring to:

After returning drives to windows and performing a real shutdown they worked normally in other systems.

Windows would only cause problem on only one of OP’s disk as only one of them has NTFS, it could do nothing wierd to two other ext4 disks.

I wonder if OP is mounting using some systemd .mount units or just let udevil do it automatically (those mountpoints under /var/media). If it is udevil then the permission is probably not correct, some uid options might be used as default to avoid Kodi not being able to correctly read them.

Sharing the mount info might be helpful to solve the problem:

mount

This should be executed via SSH