Unable to install emulator

I’m using coreelec with s912 box tanix tx9 pro. I installed IAGL and I played snes game with no issue. But I’m not able to install any other emulator. I tried two psx emulator with different version and also Sega emulator. When I click the button install a message appear “install failed”
Do you know the reason?

I made some other tests.
After the message “Install failed” appeared, I was not able to install any other add on from Kodi or coreelec repo. I restarted the devise and i was able to install them. I install PS1 emulator and other one.
When i try to launch a Playstation game, i click the button download and when i’m trying to launch the game, the button appear in gray and nothing happened. After that i’m not able to launch any addon installation : message “Install failed” appear.
I’m not sure that the issue is related to emulator. I will make a debug log and post it soon.

Best regards

I was not able to reproduce the issue with the message “Install failed”. But i still not able to launch any PS1 game. Maybe playstation game are not supported well currently.

I tried to launch Tekken 2 and when i click on the button launch the button appear in grey and nothing happened.

please find below the debug log


I was able to reproduce the message “Install failed”.


I think that it’s an issue with coreelec repository.

Other thing i would like to share :
I don’t know why but i was not able to boot to coreelec. I had a boot loop after the logo coreelec appear. I decided to remake another usb drive and it work again. Maybe a problem with the usb drive. But after that i’m having some freeze during interface navigation. I don’t know why i’m facing this kind of issue because i’m using coreelec since few month without any problem. Maybe on this log there is an anwser about that freeze.