Unable to select SNES emulator in when launching game in Nexus 20.2 game menu. Black screen when lauched from RCB Deug log added. RESOVED (sort of)

Hi Folks,

i am having issue launching SNES (and Sega gensis) games from RCB after upgrading to Nexus with Kodi built in retroplayer. i upgraded RCB to Nexus version from gitgub also. i have tried all the SNES emulators and the single genesis one i can find. i dont have any other console roms to try. but same behaviour with SNES and Genisis

all was fine in 19.5. i suspected maybe some leftover as i upgraded my N2 direct and manually sorted the addons after, however, i just tired on another box (s905x) doing completley clean install but still same. if i hit pause the menu pops up and i can get to the relevent emulator setting etc but screen always black when i hit resume and no sound.

anyone else faced simialar? if not i can grab i debug log…


i guess no one has see this before…

i grabbed a debug log, not sure if it helps, it seems to suggest Kodi thinks the game has launched and is working as expected…but what do i know!

link to the log here below, any help or suggestion would be appreciated


also, not sure if related, but i tried to take RCB out of the equasion and launch a SNES rom direct from Kodi games menu, but i cant, Kodi offers me a short list of emulatars / cores to choose from (Atari, PC, various mame, Commodre and a few more) i dont have any of these installed although kodi lets me intall. most of the ones in CE repo do not show as available, and it does not show any of the cores i installed already from CE repo (the ones i installed from CE repo do show as available in RCB and can be selected but result in black screen when launching).

Update issue does appear to be specific to CE, and is apparent on 20.1 and 20.2.
i just installed nexus 20.2 x64 on my win 10 machine, from kodi game menu when i hit play on a rom i am offered the full list of cores, with all the SNES ones showing, first one i tried installed and worked, game displayed and played correctly.

the issue appears to be with zipped roms, and i was able to reproduce in Kodi on window. Kodi in windows only worked the first time, subsiqent rom launces exhibited same behavour as CE, but window kodi log gave more info - on faliure there were msg about failed to get zip, so i unzipped and tried again…it was working again.

i repeated in CE with my roms unzipped and it worked just fine

Have you ever tested a custom build ?

Maybe something like(Xenon)

Most Excellent Arcade section!!!

Just install on top of CoreELEC.

Boot is a little strange.

You will see Android vendor image
Then CoreELEC script/checksum/change log…etc
Then custom build Skin.

All CoreELEC functions still intact
Addons are merged with custom build

Happy Testing

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.