Unpackbootimg is broken - fix available

Hi Guys,
my first post here.
This tool does not work. The reason is the wrong usage of the fread function. The source assumes it returns the number of bytes read, but it returns the number of objects read (so ==1 here).
I made a quick fix on all lines using the fread. Now it works.
As I searched for the github to send a pull request, I saw that it was forked from another git. That seems to be more sophisticated and works as well (same results as my hack).
The broken repo:

The working repo:

Many regards, Dieter

What issue exactly you have? Because tool works and creates images.

it is not the mkbootimg tool that fails. It is the unpackbootimg that is badly broken.
Not used in normal builds, but I wanted to understand details about the image and therefore tried to unpack.

That bug is not that important, but I wanted to report it in case others run into the same issue.
Many regards, Dieter

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.