Unsupported ceemmc copy option

Hi,

first, I know this is unsupported so I don’t expect any answers, but maybe someone is interested or has ideas anyway.

my box is a generic s905x. two years ago (or more) I installed to emmc with ceemmc in single boot mode. now I want to start fresh but keep a working, bootable version of the current state. so I thought I use the “copy” option to make a copy to an SD card. but when I start ceemmc (-x) it gives me the options as if I was booted from SD (which I am definitely not, the SD is blank FAT).

Starting CoreELEC eMMC installation tool...

System is not supported: gxl_p212_2g!

There is NO official support by Team CoreELEC
if you continue to run this tool!
Continue? [y]: y

eMMC size: 0x0001d2000000 [8GB]

Existing CoreELEC single boot installation found on eMMC

Renew current CoreELEC single boot installation on eMMC
  Use CoreELEC data from
    [1] current used SD or USB device
    [2] existing backup on current used SD or USB device

[3] Make a backup of current CoreELEC single boot installation on eMMC to current used SD or USB device

Please choose one option? [1/2/3]:

so, no copy option. I know that it worked on this device, because back then I did copy to SD and later back to ceemmc, I was trying -ng and non-ng options.

any ideas?

Make a backup of current CoreELEC single boot installation… ??

Thank you for your reply!

But sadly no, that’s actually not the same thing. To quote from How to use the Team CoreELEC ceemmc tool

Option Backup:
This option can be used to create a backup of the current CoreELEC installation on the internal eMMC.

Also, it doesn’t work, because it wants to write to internal storage where there isn’t enough space (and it doesn’t reach the SD card anyways).

Which makes sense in the context, as ceemmc seems to think CE is booted from SD card, so it writes to /storage. But really this mountpoint isn’t on the SD card but on internal.

If I understand the how-to correctly, booted from eMMC I should get:

  [Existing CoreELEC installation on eMMC]

   [1] Make a copy of current CoreELEC installation on eMMC to current used SD or USB device
       Make a copy of all CoreELEC data on flash and/or storage
       partition on eMMC to the current used SD or USB device

Hmmm

As the guide says: boot from emmc, insert media after boot, start ceemmc and make a copy…

Steps 1 and 2 are no problem. I boot from internal, then I insert the uSD (I also get the notification).

But in step 3, when I run ceemmc, I do not get the option to copy as if booted from internal but the options as if booted from SD. As pasted in OP.

As to why, that’s the question. Maybe because that is an installation that was originally copied back and forth (booted from internal to uSD, then installed to internal again booted from uSD). It shouldn’t matter, right? And what to do?

Again, I know that my device is not supported, so I really appreciate you trying to help.