Upgrade fails with archive corrupt/invalid - no space left on device

#1

Hi

I’m running LE9.0.0 on a Beelink GT1 and it said there was an upgrade downloaded.
But on boot it reports that it failed to extract contents of archive file
result: ‘tar write error: No space left on device’ (though there is 350MB free on the partition)
Then “archive is corrupt/invalid”

Any ideas?

0 Likes

#2

The .tar file is corrupted and probably is misreporting its size as been bigger than it actually is. It will have deleted itself after it failed the upgrade. Download the .tar file manually and place it in your upgrade folder and try again.

Shoog

0 Likes

#3

Thanks - but where is the upgrade folder? I can only see device_trees.
How to install CoreELEC says “Copy the .tar file to the /storage/.update folder on your device.” but that isn’t there either.

Also I booted into CE again and it said the upgrade download had happened again but I get the same result. So how can the file keep getting corrupted?
Also I checked the partition for errors but none are reported.

0 Likes

#4

If you access your box via SAMBA there will be a folder called upgrade - place the tar in there.

I am a little confused, in your opening comment you say you are running LE, so if that is the case then your upgrade that is causing problems is an LE upgrade (it could not be accessing the CE download links). So your problem is a with an LE upgrade and has nothing to do with CE. Am I reading your comments correctly ?

If you are running LE and trying to move to CE then the only recognised method is to run the CE as a fresh install off of an SD card. If you then want to load it onto your boxes NAND/eMMC then you can attempt the unsupported “installtointernal” which will give you a completely clean install of CE.

A bit of clarification seems in order.

Shoog

0 Likes

#5

Apologies for the typo - I’m running CE9.0.0 running off the sd-card. The latter is where I was looking for an update/upgrade folder.

0 Likes

#6

Use SAMBA, try adding the upgrade .tar file over the network and see if it upgrades successfully. upgrade is one of the standard SAMBA shares created by Coreelec so it has to be there. Once you have loaded the ,tar file reboot and report back what happens.

otherwise you will not find the folder simply by browsing the SD card since it is a hidden folder.

If however you don’t feel the need to upgrade then simply go into Coreelec settings and disable automatic upgrade and that will stop your messages.

Shoog

0 Likes

#7

I compared file hashes for the existing file that was visible via samba in the update folder with a downloaded tar file and they were the same, so the CE-downloaded file wasn’t corrupt. But I copied it over anyway, rebooted and the update failed with the same error.

So is it really out of space? As before the sd-card partition has 350MB free but is the update process using different space somehow? All the media is on the network so there’s nothing stored locally.

0 Likes

#8

Something has gotten corrupted so I suggest a different approach:
1- create a backup of your current system
2-using the Libreelec SD card creator tool create a fresh install of the version you want on a new SD card.
3- check that this boots up
4- restore your backup

Shoog

0 Likes

#9

If you have not enough space than you can connect you sd card to windows PC and replace kernel
, system and dtb.img files with files from update archive.
You have to know what dtb file you use and copy from archive and rename correct one.

PS: you can copy files from sd as first step to return them back if you will do something wrong.

0 Likes

#10

OK I’ve found that CE reports another filesystem mounted on /storage, which has only got 144MB left - as it’s only a 1GB sd-card.

I used MiniTool Partition Wizard to shrink the FAT partition but for some reason it can’t extend the Ext4 one.

Maybe I just get a bigger sd-card!

0 Likes

#11

1Gb is fairly marginal since the upgrade process involves having the .tar file along with the currently running system and the decompressed upgrade image all on the storage at the same time.
Book2K3’s suggestion should work to get you upgraded - but getting a larger SD card will save you hitting the same issue the next time a release is issued.

Shoog

0 Likes

#12

Yep there lies your problem, it downloaded the file but there was not enough space on your device to store the whole update.

1GB card is far too small the fat partition will use at least half of that leaving less than 500mb for Kodi/addons/databases/artwork/logs and updates.

There is a reason the fat partition is 500mb and that’s to allow the system image to increase and leave room to grow, if you reduce it then you are asking for trouble in the future.

0 Likes

#13

Ok tx for the info. It might be an idea to add the min recommended size sd-card in the Installation Guide.

0 Likes