Upgrade on a pre-installed eMMC (going from 9.2.7 to 19.1)

Hello.

I bought few days ago a N2+ with an eMMC pre-loaded with CE 9.2.7.
I wanted to upgrade it to 19.1.

I have a USB reader.
Just downloaded the image CoreELEC-Amlogic-ng.arm-19.1-Matrix-Odroid_N2.img.gz.
Used Etcher to flash the emmc and replaced the dtb.img in the root directory with g12b_s922x_odroid_n2.dtb

Then, the N2+ doesn’t boot at all. The blue led doesn’t flash.

Is there something else to do than just flashing the new image ? Is the bootloader on the hidden partition (seen from Windows) to be updated as well ?

Thank you.
François

You don’t have to replace any file - just write N2 image and that’s it.

[EDIT]

I tried one more time with Rufus this time and it worked.
Many thanks for the support
François


Thank you.

I tried to flash the image many times, with etcher and win32diskimager, also with multiple downolads of the image.
None of my trials worked.
When booting with the SPI switch on, I’m getting an error message, “Failed to launch petitboot, dropping to a shell”.

I have a preloaded eMMC with Android Pie on it and this one works.

Can I consider my petitboot the culprit ?
Or is that the eMMC card that became faulty and because of that petitboot breaks when loading ?

François

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice